aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 19:44:02 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-27 19:48:07 +0000
commita2663b5d194c51e28906bfbc7f741312501cdc68 (patch)
tree92140ba89a4465ac5a60ecfd4dca8de1beac7406
parent210e8d9ee1c8909256d661eb4fa01990745cf014 (diff)
downloadports-a2663b5d194c51e28906bfbc7f741312501cdc68.tar.gz
ports-a2663b5d194c51e28906bfbc7f741312501cdc68.zip
devel/py-pythonfinder: Add py-pythonfinder 1.2.8
PythonFinder is a cross-platform search tool for finding Pythons. WWW: https://github.com/sarugaku/pythonfinder
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pythonfinder/Makefile26
-rw-r--r--devel/py-pythonfinder/distinfo3
-rw-r--r--devel/py-pythonfinder/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 70469a516457..8b0858b9249a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5071,6 +5071,7 @@
SUBDIR += py-python-subunit
SUBDIR += py-pythonbrew
SUBDIR += py-pythondialog
+ SUBDIR += py-pythonfinder
SUBDIR += py-pytimeparse
SUBDIR += py-pytools
SUBDIR += py-pytrie
diff --git a/devel/py-pythonfinder/Makefile b/devel/py-pythonfinder/Makefile
new file mode 100644
index 000000000000..153ce610c4e5
--- /dev/null
+++ b/devel/py-pythonfinder/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pythonfinder
+PORTVERSION= 1.2.8
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python discovery tool to help locate python on any system
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cached-property>=0:devel/py-cached-property@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pythonfinder/distinfo b/devel/py-pythonfinder/distinfo
new file mode 100644
index 000000000000..3ee3b830bd2c
--- /dev/null
+++ b/devel/py-pythonfinder/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632760426
+SHA256 (pythonfinder-1.2.8.tar.gz) = e3ea90d327f2ff61a692af9326deced042bb27f6fd562fc788637abee9bd62d9
+SIZE (pythonfinder-1.2.8.tar.gz) = 43719
diff --git a/devel/py-pythonfinder/pkg-descr b/devel/py-pythonfinder/pkg-descr
new file mode 100644
index 000000000000..14f0573e9d46
--- /dev/null
+++ b/devel/py-pythonfinder/pkg-descr
@@ -0,0 +1,3 @@
+PythonFinder is a cross-platform search tool for finding Pythons.
+
+WWW: https://github.com/sarugaku/pythonfinder