aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-16 18:24:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-16 18:24:44 +0000
commita2b4a671a27e794667c0d175432d2ef4bf3ffcc1 (patch)
tree101c480f1f7f362592846b537048c1f0df54f53a
parent1606c0ace4f5895ddce2a5fb4d01431b4fe9095c (diff)
downloadports-a2b4a671a27e794667c0d175432d2ef4bf3ffcc1.tar.gz
ports-a2b4a671a27e794667c0d175432d2ef4bf3ffcc1.zip
science/dakota: Update 6.15.0 -> 6.16.0
-rw-r--r--science/dakota/Makefile18
-rw-r--r--science/dakota/distinfo6
-rw-r--r--science/dakota/files/patch-DakotaBoostDLLimport30
-rw-r--r--science/dakota/files/patch-packages_external_sciplot_SciPlot.c22
-rw-r--r--science/dakota/pkg-plist16
5 files changed, 60 insertions, 32 deletions
diff --git a/science/dakota/Makefile b/science/dakota/Makefile
index 824252641ab1..bc86b5c8a94d 100644
--- a/science/dakota/Makefile
+++ b/science/dakota/Makefile
@@ -1,6 +1,5 @@
PORTNAME= dakota
-DISTVERSION= 6.15.0
-PORTREVISION= 2
+DISTVERSION= 6.16.0
CATEGORIES= science
MASTER_SITES= https://dakota.sandia.gov/sites/default/files/distributions/public/
DISTNAME= ${PORTNAME}-${DISTVERSION}-public-src-cli
@@ -15,15 +14,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= nanoflann>0:math/nanoflann
LIB_DEPENDS= libblas.so:math/blas \
libboost_system.so:devel/boost-libs \
+ libexpat.so:textproc/expat2 \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libgsl.so:math/gsl \
libhdf5.so:science/hdf5 \
+ libicui18n.so:devel/icu \
liblapack.so:math/lapack \
libnlopt.so:math/nlopt \
- libsz.so:science/libaec
+ libpng16.so:graphics/png \
+ libsz.so:science/szip
RUN_DEPENDS= bash:shells/bash
-USES= cmake compiler:c++11-lang fortran motif perl5 pkgconfig python shebangfix xorg
-USE_XORG= ice sm x11 xau xdmcp xext xft xmu xrender xt
+USES= cmake compiler:c++11-lang fortran gettext-runtime jpeg motif perl5 pkgconfig python shebangfix xorg
+USE_XORG= ice sm x11 xau xcb xdmcp xext xft xmu xrender xt
USE_LDCONFIG= yes
USE_GITHUB= nodefault
@@ -50,13 +54,13 @@ CMAKE_ON+= DAKOTA_HAVE_GSL DAKOTA_HAVE_HDF5
CMAKE_OFF= DAKOTA_ENABLE_TESTS
CMAKE_ARGS= -DDakota_VERSION_SRC:STRING=${DISTVERSION} -DDakota_GIT_REVL:STRING=unknown -DDakota_RELEASE_DATE:${STRING}=20211115 \
-DPython_EXECUTABLE=${PYTHON_CMD} \
- -DMUQ_STANMATH_DIR=${WRKSRC}/stanmath
+ -DMUQ_STANMATH_DIR=${WRKSRC}/stanmath \
+ -DPython_EXECUTABLE=${PYTHON_CMD}
FFLAGS+= -fallow-argument-mismatch
LDFLAGS+= -lexecinfo
CONFLICTS_BUILD= dakota # self: picks up some bundled packages from the pre-installed dakota package and then fails to install them
-CONFLICTS_INSTALL= openblas
post-extract:
@${FIND} ${WRKSRC} -name "*.orig" -delete
diff --git a/science/dakota/distinfo b/science/dakota/distinfo
index 49d3033add70..04dbc6a736aa 100644
--- a/science/dakota/distinfo
+++ b/science/dakota/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1643858651
-SHA256 (dakota-6.15.0-public-src-cli.tar.gz) = b6d971b7d6fe913aa64fef29cf8fcf55d0e5339f9f55fb164e3cc38716b48f61
-SIZE (dakota-6.15.0-public-src-cli.tar.gz) = 125618819
+TIMESTAMP = 1655340859
+SHA256 (dakota-6.16.0-public-src-cli.tar.gz) = 49684ade2a937465d85b0fc69c96408be38bc1603ed2e7e8156d93eee3567d2f
+SIZE (dakota-6.16.0-public-src-cli.tar.gz) = 124726774
SHA256 (stan-dev-math-v2.18.0_GH0.tar.gz) = 53fbce2b28aea76695af7a91f51fdd356367153fc42b3573e2b91e6586eca91d
SIZE (stan-dev-math-v2.18.0_GH0.tar.gz) = 17528084
diff --git a/science/dakota/files/patch-DakotaBoostDLLimport b/science/dakota/files/patch-DakotaBoostDLLimport
new file mode 100644
index 000000000000..3c1b4fbc2378
--- /dev/null
+++ b/science/dakota/files/patch-DakotaBoostDLLimport
@@ -0,0 +1,30 @@
+- patch from upstream received through the ML for latest Boost version issues.
+
+diff --git src/PluginInterface.cpp src/PluginInterface.cpp
+index 60f4008..953ad0e 100644
+--- src/PluginInterface.cpp
++++ src/PluginInterface.cpp
+@@ -13,6 +13,14 @@
+ #include <boost/dll/import.hpp>
+ #include <boost/filesystem.hpp>
+
++// Boost 1.76 and newer avoid the C++20 import keyword
++// RATIONALE: Using preprocessor as isolated to this compilation unit
++#if BOOST_VERSION >= 107600
++#define dakota_boost_dll_import boost::dll::import_symbol
++#else
++#define dakota_boost_dll_import boost::dll::import
++#endif
++
+
+ namespace Dakota {
+
+@@ -111,7 +119,7 @@ void PluginInterface::load_plugin()
+ {
+ if (pluginInterface) return;
+ try {
+- pluginInterface = boost::dll::import<DakotaPlugins::DakotaInterfaceAPI>
++ pluginInterface = dakota_boost_dll_import<DakotaPlugins::DakotaInterfaceAPI>
+ (pluginPath,
+ "dakota_interface_plugin" // name of the symbol to import
+ // TODO: append .dll, .so, .dylib via
diff --git a/science/dakota/files/patch-packages_external_sciplot_SciPlot.c b/science/dakota/files/patch-packages_external_sciplot_SciPlot.c
deleted file mode 100644
index 01edfb116b20..000000000000
--- a/science/dakota/files/patch-packages_external_sciplot_SciPlot.c
+++ /dev/null
@@ -1,22 +0,0 @@
-- reported to the ML on 2022-02-01
-
---- packages/external/sciplot/SciPlot.c.orig 2022-02-01 09:03:55 UTC
-+++ packages/external/sciplot/SciPlot.c
-@@ -3761,7 +3761,7 @@ realpair* SciPlotListReturnPtr (Widget wi, int idnum,
- SciPlotList *p;
- SciPlotWidget w;
- if (!XtIsSciPlot(wi))
-- return;
-+ return NULL;
- w = (SciPlotWidget) wi;
-
- p = _ListFind(w, idnum);
-@@ -3792,7 +3792,7 @@ Boolean SciPlotQuickUpdateCheck (Widget wi)
- {
- SciPlotWidget w;
- if (!XtIsSciPlot(wi))
-- return;
-+ return NULL;
- w = (SciPlotWidget) wi;
-
- return CheckMinMax(w);
diff --git a/science/dakota/pkg-plist b/science/dakota/pkg-plist
index 4d51517d9768..c013407552cd 100644
--- a/science/dakota/pkg-plist
+++ b/science/dakota/pkg-plist
@@ -31,6 +31,7 @@ include/APPSOptimizer.hpp
include/ActiveKey.hpp
include/ActiveSubspaceModel.hpp
include/AdaptedBasisModel.hpp
+include/AdapterModel.hpp
include/AlgorithmConfig.hpp
include/AlgorithmConfig.hpp.inl
include/AllOperators.hpp
@@ -136,6 +137,7 @@ include/DakotaConstraints.hpp
include/DakotaEnvironment.hpp
include/DakotaGraphics.hpp
include/DakotaInterface.hpp
+include/DakotaInterfaceAPI.hpp
include/DakotaIterator.hpp
include/DakotaLeastSq.hpp
include/DakotaMinimizer.hpp
@@ -219,6 +221,7 @@ include/EffGlobalMinimizer.hpp
include/ElitistSelector.hpp
include/ElitistSelector.hpp.inl
include/EmbedHybridMetaIterator.hpp
+include/EnsembleSurrModel.hpp
include/EqConstrainedLSQSolver.hpp
include/EqualityConstraintType.hpp
include/EqualityConstraintType.hpp.inl
@@ -476,6 +479,7 @@ include/MetricTrackerConvergerBase.hpp
include/MetricTrackerConvergerBase.hpp.inl
include/MinimizeObjectiveFunctionType.hpp
include/MinimizeObjectiveFunctionType.hpp.inl
+include/MinimizerAdapterModel.hpp
include/MixedVarConstraints.hpp
include/MixedVariables.hpp
include/MorseSmaleComplex.hpp
@@ -659,6 +663,7 @@ include/PecosApproximation.hpp
include/PenaltyFitnessAssessorBase.hpp
include/PenaltyFitnessAssessorBase.hpp.inl
include/PiecewiseInterpPolynomial.hpp
+include/PluginInterface.hpp
include/PluginParallelDirectApplicInterface.hpp
include/PluginSerialDirectApplicInterface.hpp
include/PoissonRandomVariable.hpp
@@ -2578,7 +2583,11 @@ lib/libutilities.so
%%DATADIR%%/LICENSE
%%DATADIR%%/LICENSE_HOPSPACK
%%DATADIR%%/Python/dakota/__init__.py
+%%DATADIR%%/Python/dakota/__pycache__/__init__.cpython-36.pyc
%%DATADIR%%/Python/dakota/interfacing/__init__.py
+%%DATADIR%%/Python/dakota/interfacing/__pycache__/__init__.cpython-36.pyc
+%%DATADIR%%/Python/dakota/interfacing/__pycache__/dprepro.cpython-36.pyc
+%%DATADIR%%/Python/dakota/interfacing/__pycache__/interfacing.cpython-36.pyc
%%DATADIR%%/Python/dakota/interfacing/dprepro.py
%%DATADIR%%/Python/dakota/interfacing/interfacing.py
%%DATADIR%%/Python/dakota/interfacing/parallel.py
@@ -2596,3 +2605,10 @@ lib/libutilities.so
%%DATADIR%%/examples/hopspack/5-multi-start/example5_params.txt
%%DATADIR%%/examples/hopspack/5-multi-start/multi_start
%%DATADIR%%/examples/hopspack/README.txt
+%%DATADIR%%/plugins/CMakeLists.txt
+%%DATADIR%%/plugins/DakotaInterfaceAPI.hpp
+%%DATADIR%%/plugins/DakotaPythonPlugin.cpp
+%%DATADIR%%/plugins/DakotaPythonPlugin.hpp
+%%DATADIR%%/plugins/PluginIdentityMap.cpp
+%%DATADIR%%/plugins/PluginIdentityMap.hpp
+%%DATADIR%%/plugins/dakota_symbol_visibility.hpp