aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:44:01 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:40 +0000
commita2ee9608c313978137291dfb8090a265322a6368 (patch)
treeea5661f787f04e0feec9ee24bccb30c11cf8be30
parentc62750f66957f5ac547e6b8b6c1625841ed8adf6 (diff)
downloadports-a2ee9608c313978137291dfb8090a265322a6368.tar.gz
ports-a2ee9608c313978137291dfb8090a265322a6368.zip
devel/py-hatch-fancy-pypi-readme: Convert to USE_PYTHON=pep517
- Add NO_ARCH - Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-hatch-fancy-pypi-readme/Makefile9
-rw-r--r--devel/py-hatch-fancy-pypi-readme/files/setup.py55
2 files changed, 4 insertions, 60 deletions
diff --git a/devel/py-hatch-fancy-pypi-readme/Makefile b/devel/py-hatch-fancy-pypi-readme/Makefile
index 891ba6e72811..94e33361d792 100644
--- a/devel/py-hatch-fancy-pypi-readme/Makefile
+++ b/devel/py-hatch-fancy-pypi-readme/Makefile
@@ -1,5 +1,6 @@
PORTNAME= hatch-fancy-pypi-readme
PORTVERSION= 22.8.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,12 +13,13 @@ WWW= https://github.com/hynek/hatch-fancy-pypi-readme
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
-#NO_ARCH= yes
+NO_ARCH= yes
.include <bsd.port.pre.mk>
@@ -29,7 +31,4 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extens
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=0:textproc/py-tomli@${PY_FLAVOR}
.endif
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.post.mk>
diff --git a/devel/py-hatch-fancy-pypi-readme/files/setup.py b/devel/py-hatch-fancy-pypi-readme/files/setup.py
deleted file mode 100644
index 61788718446f..000000000000
--- a/devel/py-hatch-fancy-pypi-readme/files/setup.py
+++ /dev/null
@@ -1,55 +0,0 @@
-# -*- coding: utf-8 -*-
-from setuptools import setup
-
-setup(
- name='hatch-fancy-pypi-readme',
- version='%%PORTVERSION%%',
- description='Fancy PyPI READMEs with Hatch',
- long_description='# Your ✨Fancy✨ Project Deserves a ✨Fancy✨ PyPI Readme! 🧐\n\n[![PyPI - Version](https://img.shields.io/pypi/v/hatch-fancy-pypi-readme.svg)](https://pypi.org/project/hatch-fancy-pypi-readme)\n[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/hatch-fancy-pypi-readme.svg)](https://pypi.org/project/hatch-fancy-pypi-readme)\n[![Hatch project](https://img.shields.io/badge/%F0%9F%A5%9A-Hatch-4051b5.svg)](https://github.com/pypa/hatch)\n[![License: MIT](https://img.shields.io/badge/license-MIT-C06524)](https://github.com/hynek/hatch-fancy-pypi-readme/blob/main/LICENSE.txt)\n\n\n*hatch-fancy-pypi-readme* is an MIT-licensed metadata plugin for [*Hatch*](https://hatch.pypa.io/).\n\nIts purpose is to help you to have fancy PyPI readmes – unlike *this* one you’re looking at right now.\n\nPlease check out the [documentation](https://github.com/hynek/hatch-fancy-pypi-readme#readme) to see what *hatch-fancy-pypi-readme* can do for you and your projects!\n',
- author_email='Hynek Schlawack <hs@ox.cx>',
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Framework :: Hatch',
- 'License :: OSI Approved :: MIT License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: 3.9',
- 'Programming Language :: Python :: 3.10',
- 'Programming Language :: Python :: 3.11',
- 'Programming Language :: Python :: Implementation :: CPython',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Topic :: Software Development :: Build Tools',
- ],
- install_requires=[
- 'hatchling',
- 'tomli; python_version < "3.11"',
- 'typing-extensions; python_version < "3.8"',
- ],
- extras_require={
- 'dev': [
- 'hatch-fancy-pypi-readme[tests]',
- 'mypy',
- ],
- 'tests': [
- 'build',
- 'pytest',
- 'wheel',
- ],
- },
- entry_points={
- 'console_scripts': [
- 'hatch-fancy-pypi-readme = hatch_fancy_pypi_readme.__main__:main',
- ],
- 'hatch': [
- 'fancy-pypi-readme = hatch_fancy_pypi_readme.hooks',
- ],
- },
- packages=[
- 'hatch_fancy_pypi_readme',
- ],
- package_dir={
- '': 'src',
- },
-)