aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-09-05 10:16:47 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2023-09-05 10:16:47 +0000
commita407c7abf1d805f5f926ad30fe94e71a12dde245 (patch)
tree6e242b1285cdc2b2b94a7196952bf13884962bf6
parentb9558252b1049241e9f0956884ca50980a8d6b13 (diff)
downloadports-a407c7abf1d805f5f926ad30fe94e71a12dde245.tar.gz
ports-a407c7abf1d805f5f926ad30fe94e71a12dde245.zip
emulators/pcsx2: Unbreak with kern.elf64.allow_wx=0
PR: 273573 Reported by: jbeich
-rw-r--r--emulators/pcsx2/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/emulators/pcsx2/Makefile b/emulators/pcsx2/Makefile
index 70f8932b7a8d..df7a5a1c720a 100644
--- a/emulators/pcsx2/Makefile
+++ b/emulators/pcsx2/Makefile
@@ -1,6 +1,7 @@
PORTNAME= pcsx2
PORTVERSION= 1.7.4970
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org
@@ -30,7 +31,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libbacktrace.so:devel/libbacktrace
USES= cmake compiler:c++20-lang \
- desktop-file-utils gl pkgconfig qt:6 sdl xorg
+ desktop-file-utils elfctl gl pkgconfig qt:6 sdl xorg
USE_GITHUB= yes
GH_PROJECT= pcsx2
@@ -40,6 +41,7 @@ USE_GL= egl
USE_SDL= sdl2
USE_XORG= ice x11 xcb xext xpm xrandr
USE_QT= base tools
+ELF_FEATURES= +wxneeded:bin/pcsx2-qt
# SSE 4.1 instructions are a hard requirement, if CPUTYPE is defined
# use whatever is set and let the build fail if it falls below