aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2023-04-20 20:56:22 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2023-04-20 22:01:41 +0000
commita4f61b09f6f15e3570652acb9c24200072878845 (patch)
tree503f2dcd008d0c21f7f036e9ffd63161ab5be7fc
parent9523c6bffa8dfc6ae1a6842f5e1720885a164b90 (diff)
downloadports-a4f61b09f6f15e3570652acb9c24200072878845.tar.gz
ports-a4f61b09f6f15e3570652acb9c24200072878845.zip
math/readstat: another attempt at getting clang16 on FreeBSD14 to compile this
-rw-r--r--math/readstat/Makefile2
-rw-r--r--math/readstat/files/patch-src_bin_readstat.c11
-rw-r--r--math/readstat/files/patch-src_readstat__parser.c11
-rw-r--r--math/readstat/files/patch-src_readstat__variable.c10
-rw-r--r--math/readstat/files/patch-src_sas_ieee.c11
-rw-r--r--math/readstat/files/patch-src_spss_readstat__por.c11
-rw-r--r--math/readstat/files/patch-src_spss_readstat__por__write.c11
7 files changed, 62 insertions, 5 deletions
diff --git a/math/readstat/Makefile b/math/readstat/Makefile
index bfdce5912113..ed5a13ebbe3d 100644
--- a/math/readstat/Makefile
+++ b/math/readstat/Makefile
@@ -1,6 +1,6 @@
PORTNAME= readstat
DISTVERSION= 1.1.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math kde
MASTER_SITES= https://github.com/WizardMac/ReadStat/releases/download/v${DISTVERSION}/
diff --git a/math/readstat/files/patch-src_bin_readstat.c b/math/readstat/files/patch-src_bin_readstat.c
new file mode 100644
index 000000000000..d589da2957f9
--- /dev/null
+++ b/math/readstat/files/patch-src_bin_readstat.c
@@ -0,0 +1,11 @@
+--- src/bin/readstat.c.orig 2023-04-20 20:55:14 UTC
++++ src/bin/readstat.c
+@@ -154,7 +154,7 @@ readstat_error_t parse_file(readstat_parser_t *parser,
+ return error;
+ }
+
+-static void print_version() {
++static void print_version(void) {
+ fprintf(stdout, "ReadStat version " READSTAT_VERSION "\n");
+ }
+
diff --git a/math/readstat/files/patch-src_readstat__parser.c b/math/readstat/files/patch-src_readstat__parser.c
new file mode 100644
index 000000000000..861d0a24adf2
--- /dev/null
+++ b/math/readstat/files/patch-src_readstat__parser.c
@@ -0,0 +1,11 @@
+--- src/readstat_parser.c.orig 2023-04-20 20:54:06 UTC
++++ src/readstat_parser.c
+@@ -3,7 +3,7 @@
+ #include "readstat.h"
+ #include "readstat_io_unistd.h"
+
+-readstat_parser_t *readstat_parser_init() {
++readstat_parser_t *readstat_parser_init(void) {
+ readstat_parser_t *parser = calloc(1, sizeof(readstat_parser_t));
+ parser->io = calloc(1, sizeof(readstat_io_t));
+ if (unistd_io_init(parser) != READSTAT_OK) {
diff --git a/math/readstat/files/patch-src_readstat__variable.c b/math/readstat/files/patch-src_readstat__variable.c
index 699c88937a9e..4bc2fe0c7ad8 100644
--- a/math/readstat/files/patch-src_readstat__variable.c
+++ b/math/readstat/files/patch-src_readstat__variable.c
@@ -1,6 +1,6 @@
---- src/readstat_variable.c.orig 2023-02-19 12:39:09 UTC
+--- src/readstat_variable.c.orig 2020-08-25 16:29:50 UTC
+++ src/readstat_variable.c
-@@ -2,7 +2,7 @@
+@@ -2,10 +2,10 @@
#include <stdlib.h>
#include "readstat.h"
@@ -8,4 +8,8 @@
+static readstat_value_t make_blank_value(void);
static readstat_value_t make_double_value(double dval);
- static readstat_value_t make_blank_value() {
+-static readstat_value_t make_blank_value() {
++static readstat_value_t make_blank_value(void) {
+ readstat_value_t value = { .is_system_missing = 1, .v = { .double_value = NAN }, .type = READSTAT_TYPE_DOUBLE };
+ return value;
+ }
diff --git a/math/readstat/files/patch-src_sas_ieee.c b/math/readstat/files/patch-src_sas_ieee.c
index beab46c1713d..40efd45c642b 100644
--- a/math/readstat/files/patch-src_sas_ieee.c
+++ b/math/readstat/files/patch-src_sas_ieee.c
@@ -1,4 +1,4 @@
---- src/sas/ieee.c.orig 2023-02-19 12:37:34 UTC
+--- src/sas/ieee.c.orig 2018-12-15 15:27:55 UTC
+++ src/sas/ieee.c
@@ -16,7 +16,7 @@ static void ieee2xpt(unsigned char *ieee, unsigned cha
@@ -9,3 +9,12 @@
#endif
void memreverse(void *intp_void, int l) {
+@@ -96,7 +96,7 @@ int cnxptiee(const void *from_bytes, int fromtype, voi
+ return(0);
+ }
+
+-int get_native() {
++int get_native(void) {
+ static unsigned char float_reps[][8] = {
+ {0x41,0x10,0x00,0x00,0x00,0x00,0x00,0x00},
+ {0x3f,0xf0,0x00,0x00,0x00,0x00,0x00,0x00},
diff --git a/math/readstat/files/patch-src_spss_readstat__por.c b/math/readstat/files/patch-src_spss_readstat__por.c
new file mode 100644
index 000000000000..7037c78f2188
--- /dev/null
+++ b/math/readstat/files/patch-src_spss_readstat__por.c
@@ -0,0 +1,11 @@
+--- src/spss/readstat_por.c.orig 2023-04-20 20:55:14 UTC
++++ src/spss/readstat_por.c
+@@ -64,7 +64,7 @@ uint16_t por_unicode_lookup[256] = {
+ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
+ 0, 0, 0, 0, 0, 0 };
+
+-por_ctx_t *por_ctx_init() {
++por_ctx_t *por_ctx_init(void) {
+ por_ctx_t *ctx = calloc(1, sizeof(por_ctx_t));
+
+ ctx->space = ' ';
diff --git a/math/readstat/files/patch-src_spss_readstat__por__write.c b/math/readstat/files/patch-src_spss_readstat__por__write.c
new file mode 100644
index 000000000000..048433212898
--- /dev/null
+++ b/math/readstat/files/patch-src_spss_readstat__por__write.c
@@ -0,0 +1,11 @@
+--- src/spss/readstat_por_write.c.orig 2023-04-20 20:55:14 UTC
++++ src/spss/readstat_por_write.c
+@@ -167,7 +167,7 @@ static readstat_error_t por_write_string_field(readsta
+ return por_write_string_field_n(writer, ctx, string, strlen(string));
+ }
+
+-static por_write_ctx_t *por_write_ctx_init() {
++static por_write_ctx_t *por_write_ctx_init(void) {
+ por_write_ctx_t *ctx = calloc(1, sizeof(por_write_ctx_t));
+ uint16_t max_unicode = 0;
+ int i;