aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-10-21 14:41:23 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-10-21 14:43:23 +0000
commita5526837674995dd0eb7ce5dbeb4d7dd1735db77 (patch)
tree384bfaf63a7c9a4eac4f373704fa414284b04fe1
parentb02b8e43bc56f1255c55e99fe0531587e8f215bd (diff)
downloadports-a5526837674995dd0eb7ce5dbeb4d7dd1735db77.tar.gz
ports-a5526837674995dd0eb7ce5dbeb4d7dd1735db77.zip
math/nauty: Remove NATIVE option
This breaks on non amd64 platforms and we already have CPUTYPE that handles this type of optimization. Use "safe" optimization for all platforms PR: 272657 Approved by: portmgr (maintainer timeout, 2+ months)
-rw-r--r--math/nauty/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/math/nauty/Makefile b/math/nauty/Makefile
index b2195033d8de..c9f73459b98a 100644
--- a/math/nauty/Makefile
+++ b/math/nauty/Makefile
@@ -1,10 +1,11 @@
PORTNAME= nauty
-PORTVERSION= 2.8.6
+DISTVERSION= 2.8.6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= math
MASTER_SITES= https://users.cecs.anu.edu.au/~bdm/nauty/ \
https://pallini.di.uniroma1.it/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/g}
+DISTNAME= ${PORTNAME}${DISTVERSION:S/./_/g}
MAINTAINER= moritz@schmi.tt
COMMENT= Nauty & Traces are programs for computing graph automorphism
@@ -15,18 +16,20 @@ LICENSE= APACHE20
USES= gmake
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-tls # this makes nauty thread-safe, math/libnormaliz requires nauty with tls
+CONFIGURE_ARGS= --enable-tls --disable-clz ${CONFIGURE_ARGS_${ARCH}} # this makes nauty thread-safe, math/libnormaliz requires nauty with tls
+CONFIGURE_ARGS_aarch64= --enable-popcnt
+CONFIGURE_ARGS_amd64= --enable-popcnt
+CONFIGURE_ARGS_armv7= --enable-popcnt
+CONFIGURE_ARGS_i386= --disable-popcnt
+CONFIGURE_ARGS_powerpc64= --disable-popcnt
+CONFIGURE_ARGS_riscv64= --disable-popcnt
MAKEFILE= makefile
MAKE_ARGS= includedir=${PREFIX}/include/${PORTNAME} # place headers into a dedicated directory
TEST_TARGET= check
-OPTIONS_DEFINE= DOCS NATIVE
-
-NATIVE_DESC= Build with native optimizations (-march=native, etc)
-NATIVE_CONFIGURE_ON= --disable-generic --enable-clz --enable-popcnt
-NATIVE_CONFIGURE_OFF= --enable-generic --disable-clz --disable-popcnt
+OPTIONS_DEFINE= DOCS
post-build: # build shared libraries: based on how static libraries are created
# rebuild .o files with -fPIC