aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-03-30 17:36:50 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-03-30 17:36:50 +0000
commita60237f6826d3a95002e9e843357e4eab2ccbfc6 (patch)
tree1444030f25633cbe487be6f0c31b105949912201
parent1b791d13163fe15a519253a819c0a9f3db9631c4 (diff)
downloadports-a60237f6826d3a95002e9e843357e4eab2ccbfc6.tar.gz
ports-a60237f6826d3a95002e9e843357e4eab2ccbfc6.zip
irc/bitchx: undeprecate the port and assume maintainership thereof
Try to address incompatible function pointer types warnings better: for `fserv' plugin, just force the expected type with explicit cast as offending function does not use its arguments; disable `arcfour' plugin for the time being because this case requires a deeper look.
-rw-r--r--irc/bitchx/Makefile18
-rw-r--r--irc/bitchx/pkg-plist2
2 files changed, 6 insertions, 14 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 023fb3ec6181..418bc460ce55 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -5,21 +5,17 @@ PORTEPOCH= 1
CATEGORIES+= irc
MASTER_SITES= SF/${PORTNAME}/ircii-pana/${PORTNAME}-${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Feature-rich scriptable IRC client
WWW= http://www.bitchx.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-DEPRECATED= Last stable release 2014, last upstream commit in 2019. There have been multiple concerns over security and it also lacks unicode support. Please consider using irc/irssi
-EXPIRATION_DATE=2024-03-31
-
USES= cpe gmake ncurses
-
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
-CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
+CONFIGURE_ARGS= --exec-prefix="${PREFIX}/share" \
--bindir="${PREFIX}/bin" \
--datadir="${PREFIX}/share" \
--libdir="${PREFIX}/share"
@@ -47,18 +43,14 @@ PLUGINS_CONFIGURE_WITH= plugins="${PLUGIN_LIST:C/\$$/,/g}"
SSL_USES= ssl
SSL_CONFIGURE_WITH= ssl="${OPENSSLBASE}"
-PLUGIN_LIST= abot acro arcfour autocycle blowfish cavlink cdrom encrypt \
+PLUGIN_LIST= abot acro autocycle blowfish cavlink cdrom encrypt \
europa fserv hint nap nicklist pkga possum qbx qmail wavplay
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
-CFLAGS+= -Wno-error=incompatible-function-pointer-types
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's|bzip2|true|g' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's|SSLeay|ERR_get_error|' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|impress_me,|(int (*)(void *, char *))&|' \
+ ${WRKSRC}/dll/fserv/fserv.c
post-patch-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/irc/bitchx/pkg-plist b/irc/bitchx/pkg-plist
index d7fb3074558d..c4363ae5b3c4 100644
--- a/irc/bitchx/pkg-plist
+++ b/irc/bitchx/pkg-plist
@@ -9,7 +9,7 @@ share/man/man1/BitchX.1.gz
@dir %%DATADIR%%/plugins
%%PLUGINS%%%%DATADIR%%/plugins/BitchX.hints
%%PLUGINS%%%%DATADIR%%/plugins/acro.so
-%%PLUGINS%%%%DATADIR%%/plugins/arcfour.so
+@comment %%PLUGINS%%%%DATADIR%%/plugins/arcfour.so
%%PLUGINS%%%%DATADIR%%/plugins/autobot.so
%%PLUGINS%%%%DATADIR%%/plugins/autocycle.so
%%PLUGINS%%%%DATADIR%%/plugins/blowfish.so