aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 14:57:29 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 15:41:46 +0000
commita669deada4d3988659e9cc81c5a36cef387cc97b (patch)
tree384e6cafda6658f2cbe3d304f2563c17c1e242ba
parentab2539f00de0d0301f473db7df736a3badff7a1d (diff)
downloadports-a669deada4d3988659e9cc81c5a36cef387cc97b.tar.gz
ports-a669deada4d3988659e9cc81c5a36cef387cc97b.zip
games/lincity-ng: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--games/lincity-ng/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/lincity-ng/Makefile b/games/lincity-ng/Makefile
index 79a6013700cf..d1689a65b570 100644
--- a/games/lincity-ng/Makefile
+++ b/games/lincity-ng/Makefile
@@ -8,21 +8,23 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Improved rich city simulation game for X
WWW= http://lincity-ng.berlios.de
-BUILD_DEPENDS= jam:devel/jam
-LIB_DEPENDS= libphysfs.so:devel/physfs
-
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= jam:devel/jam
+LIB_DEPENDS= libphysfs.so:devel/physfs
+
USES= gl gnome localbase:ldflags pkgconfig sdl tar:bzip2 xorg
-USE_SDL= sdl mixer image ttf gfx
+USE_CXXSTD= c++14
USE_GL= gl
-USE_XORG= x11
USE_GNOME= libxml2
+USE_SDL= sdl mixer image ttf gfx
+USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libphysfs=${LOCALBASE} \
--x-libraries=${LOCALBASE}/lib --x-includes=${LOCALBASE}/include
+
LDFLAGS+= -lpthread
PLIST_FILES= bin/lincity-ng \