aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 02:33:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 02:34:10 +0000
commita6a8311b884907cf8a6aac3b3b3038f5bdd34751 (patch)
treecdcdef42622bd95f00f16fed4b57e8943cc4838a
parentd8b355fa7ee5bae6995ddd2c64cd7b4354730500 (diff)
downloadports-a6a8311b884907cf8a6aac3b3b3038f5bdd34751.tar.gz
ports-a6a8311b884907cf8a6aac3b3b3038f5bdd34751.zip
science/libkml: Fix build with Clang 16
Clang 16 uses c++17 by default.
-rw-r--r--science/libkml/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/science/libkml/Makefile b/science/libkml/Makefile
index e0ea47db04f9..f545aaa97ef3 100644
--- a/science/libkml/Makefile
+++ b/science/libkml/Makefile
@@ -19,6 +19,7 @@ USES= cmake compiler:c++11-lang minizip pathfix
CMAKE_OFF= BUILD_TESTING WITH_JAVA WITH_PYTHON WITH_SWIG
CMAKE_ON= BUILD_SHARED_LIBS
LDFLAGS+= -lz
+USE_CXXSTD= c++11
USE_LDCONFIG= yes
USE_GITHUB= yes