aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 02:45:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 02:57:10 +0000
commita6ae43ffaf8447e01fb88327bad23050c70df868 (patch)
tree5ecc75a48d3dfe62c1cb260f3985ea56c28ac3f6
parente482bebba52d7c87daebce3865f4903271b29137 (diff)
downloadports-a6ae43ffaf8447e01fb88327bad23050c70df868.tar.gz
ports-a6ae43ffaf8447e01fb88327bad23050c70df868.zip
shells/ast-ksh: Mark BROKEN on 14
Fails to compile with: error: incompatible function pointer types assigning to 'int (*)(wchar_t *, const char *, size_t)' (aka 'int (*)(int *, const char *, unsigned long)') from 'size_t (wchar_t *, const char *, size_t)' (aka 'unsigned long (int *, const char *, unsigned long)') [-Wincompatible-function-pointer-types] Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--shells/ast-ksh/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/shells/ast-ksh/Makefile b/shells/ast-ksh/Makefile
index bf9efc7d3ad7..c7a4300d896e 100644
--- a/shells/ast-ksh/Makefile
+++ b/shells/ast-ksh/Makefile
@@ -22,6 +22,7 @@ LICENSE= EPL
BROKEN_aarch64= Fails to compile: needs sbrk
BROKEN_riscv64= Fails to compile: ast-ksh93v/src/lib/libast/hash/hashalloc.c:162:4: non-const lvalue reference to type '__builtin_va_list' cannot bind to a temporary of type 'va_list'
+BROKEN_FreeBSD_14= Fails to compilt: error: incompatible function pointer types assigning to 'int (*)(wchar_t *, const char *, size_t)' (aka 'int (*)(int *, const char *, unsigned long)') from 'size_t (wchar_t *, const char *, size_t)' (aka 'unsigned long (int *, const char *, unsigned long)') [-Wincompatible-function-pointer-types]
USES= compiler:c11