aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-03-09 13:38:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-03-09 13:43:13 +0000
commita779acb15993d9f8d995495ead62f7b1deb20a7c (patch)
treec837c069f38cb2e9fadb3795dfe2e503f22d02d4
parent0fc16cde22a067091718cadf2f5624d4f3e2bb6e (diff)
downloadports-a779acb15993d9f8d995495ead62f7b1deb20a7c.tar.gz
ports-a779acb15993d9f8d995495ead62f7b1deb20a7c.zip
emulators/qemu: Fix regression in gmake
This issue started popping up after the latest gmake upgrade. Although there are multiple ways of fixing this I will stick with the preferred path by tijl@ as he is trying to address the issue with other ports. As I am not sure sure whether if this triggers a different binary being generated but for the safest route bumping portrevision. This problem is not reproducible for people using poudreiere to build their ports PR: 277527 Reported by: rozhuk.im@gmail.com
-rw-r--r--emulators/qemu/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index ed8db24f93f6..1b248ad50fbc 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qemu
PORTVERSION= 8.2.2
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -240,10 +241,10 @@ post-patch-CDROM_DMA-off:
@${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/include/hw/ide/internal.h
do-build:
- cd ${WRKSRC} && ${GMAKE} -j${MAKE_JOBS_NUMBER}
+ cd ${WRKSRC} && ${SETENVI} ${WRK_ENV} ${GMAKE} -j${MAKE_JOBS_NUMBER}
do-install:
- cd ${WRKSRC} && ${SETENV} DESTDIR=${STAGEDIR} ${GMAKE} install
+ cd ${WRKSRC} && ${SETENVI} ${WRK_ENV} DESTDIR=${STAGEDIR} ${GMAKE} install
.if !target(post-install)
post-install: