aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-02-04 23:54:57 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-02-05 00:09:53 +0000
commita7ea574fa813c48faa400266edbb63c890c4abf8 (patch)
tree02f6c5b814e1419a5ddc8ad9a050ef9ab7794ed7
parent6f26e08fc9b753a86b46d827e3bb3618304cce39 (diff)
downloadports-a7ea574fa813c48faa400266edbb63c890c4abf8.tar.gz
ports-a7ea574fa813c48faa400266edbb63c890c4abf8.zip
www/nghttp2: Update to 1.59.0
Rearrange Makefile to follow Porters Handbook more closely and for readability Changelog: https://github.com/nghttp2/nghttp2/releases/tag/v1.59.0 PR: 274403 Approved by: portmgr (maintainer timeout, 2+ weeks)
-rw-r--r--www/nghttp2/Makefile42
-rw-r--r--www/nghttp2/distinfo6
2 files changed, 34 insertions, 14 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index f9874b6312c0..d387dcb64a1a 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nghttp2
-PORTVERSION= 1.58.0
+DISTVERSION= 1.59.0
CATEGORIES= www net
-MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= HTTP/2.0 C Library
@@ -10,36 +10,56 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= libnghttp2>=${PORTVERSION}:www/libnghttp2
+BUILD_DEPENDS= libnghttp2>=${DISTVERSION}:www/libnghttp2
LIB_DEPENDS= libnghttp2.so:www/libnghttp2
-USES= cmake compiler:c++14-lang cpe localbase:ldflags pathfix pkgconfig python:env shebangfix ssl tar:xz
+USES= cmake compiler:c++14-lang cpe localbase:ldflags pathfix \
+ pkgconfig python:env shebangfix ssl tar:xz
+SHEBANG_FILES= script/fetch-ocsp-response
-CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=share/man
-CMAKE_OFF= ENABLE_DEBUG ENABLE_HTTP3 ENABLE_LIB_ONLY ENABLE_STATIC_CRT ENABLE_WERROR WITH_LIBBPF WITH_MRUBY WITH_NEVERBLEED
-CMAKE_ON= ENABLE_DOC ENABLE_FAILMALLOC ENABLE_THREADS
USE_RC_SUBR= nghttpx
-SHEBANG_FILES= script/fetch-ocsp-response
+CMAKE_OFF= ENABLE_DEBUG \
+ ENABLE_HTTP3 \
+ ENABLE_LIB_ONLY \
+ ENABLE_STATIC_CRT \
+ ENABLE_WERROR \
+ WITH_LIBBPF \
+ WITH_MRUBY \
+ WITH_NEVERBLEED
+CMAKE_ON= ENABLE_DOC \
+ ENABLE_FAILMALLOC \
+ ENABLE_THREADS \
+ CMAKE_DISABLE_FIND_PACKAGE_Jemalloc \
+ CMAKE_DISABLE_FIND_PACKAGE_Libnghttp3 \
+ CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2 \
+ CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2_crypto_openssl
OPTIONS_DEFINE= APP EXAMPLES HPACK
OPTIONS_DEFAULT=APP HPACK
OPTIONS_SUB= yes
+
APP_DESC= Build h2load, nghttp, nghttpd and nghttpx
APP_BUILD_DEPENDS= c-ares>=1.7.5:dns/c-ares \
libev>=4.11:devel/libev
-APP_CMAKE_BOOL= ENABLE_APP
APP_LIB_DEPENDS= libcares.so:dns/c-ares \
libev.so:devel/libev
APP_USE= GNOME=libxml2
APP_USES= gnome
+APP_CMAKE_BOOL= ENABLE_APP
+APP_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Libev:BOOL=True \
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibXml2:BOOL=True
+
EXAMPLES_BUILD_DEPENDS= libevent>=2.0.8:devel/libevent
-EXAMPLES_CMAKE_BOOL= ENABLE_EXAMPLES
EXAMPLES_LIB_DEPENDS= libevent_openssl.so:devel/libevent
+EXAMPLES_CMAKE_BOOL= ENABLE_EXAMPLES
+EXAMPLES_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Libevent:BOOL=True
+
HPACK_BUILD_DEPENDS= jansson>=2.5:devel/jansson
-HPACK_CMAKE_BOOL= ENABLE_HPACK_TOOLS
HPACK_LIB_DEPENDS= libjansson.so:devel/jansson
+HPACK_CMAKE_BOOL= ENABLE_HPACK_TOOLS
+HPACK_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Jansson:BOOL=True
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/nghttpx/
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index 38efb1a3b0ac..62dcae04afe2 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1698848716
-SHA256 (nghttp2-1.58.0.tar.xz) = 4a68a3040da92fd9872c056d0f6b0cd60de8410de10b578f8ade9ecc14d297e0
-SIZE (nghttp2-1.58.0.tar.xz) = 1546332
+TIMESTAMP = 1705868566
+SHA256 (nghttp2-1.59.0.tar.xz) = fdc9bd71f5cf8d3fdfb63066b89364c10eb2fdeab55f3c6755cd7917b2ec4ffb
+SIZE (nghttp2-1.59.0.tar.xz) = 1546956