aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-16 12:03:30 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-16 12:03:30 +0000
commita87cbe0b5e6ad85dd21908b7943f6b11e0fb44ef (patch)
tree46d8129345b0165d72448b8eb7cae3b9ee285aee
parent2e564d3196df8c0c041c7f5054546b4189142653 (diff)
downloadports-a87cbe0b5e6ad85dd21908b7943f6b11e0fb44ef.tar.gz
ports-a87cbe0b5e6ad85dd21908b7943f6b11e0fb44ef.zip
lang/pocl: port to powerpc64
-rw-r--r--lang/pocl/Makefile11
-rw-r--r--lang/pocl/pkg-plist1
2 files changed, 10 insertions, 2 deletions
diff --git a/lang/pocl/Makefile b/lang/pocl/Makefile
index 053e00841a4f..6f6388df4e6d 100644
--- a/lang/pocl/Makefile
+++ b/lang/pocl/Makefile
@@ -9,7 +9,7 @@ COMMENT= POrtable Computing Language (POCL)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= aarch64 amd64 i386
+ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc64
ONLY_FOR_ARCHS_REASON= only tested on x86
BUILD_DEPENDS= llvm${LLVM_VERSION}>=10:devel/llvm${LLVM_VERSION} \
@@ -28,6 +28,7 @@ CMAKE_ARGS= -DWITH_LLVM_CONFIG="${LOCALBASE}/llvm${LLVM_VERSION}/bin/llvm-config
${CMAKE_ARGS_${ARCH}}
CMAKE_ARGS_aarch64= -DLLC_HOST_CPU=cortex-a53
+CMAKE_ARGS_powerpc64= -DLLC_HOST_CPU=ppc64
CMAKE_ARGS_amd64= -DKERNELLIB_HOST_CPU_VARIANTS="distro"
PLIST_SUB= CONFIGURE_TARGET=${CONFIGURE_TARGET:S/amd64/x86_64/}
@@ -44,10 +45,16 @@ DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_F
.if ${ARCH} == aarch64
PLIST_SUB+= AARCH64=""
+PLIST_SUB+= PPC64="@comment "
PLIST_SUB+= X86="@comment "
-.else
+.elif ${ARCH} == amd64 || ${ARCH} == i386
PLIST_SUB+= AARCH64="@comment "
+PLIST_SUB+= PPC64="@comment "
PLIST_SUB+= X86=""
+.else
+PLIST_SUB+= AARCH64="@comment "
+PLIST_SUB+= PPC64=""
+PLIST_SUB+= X86="@comment "
.endif
PLIST_SUB+= CONFIGURE_TARGET=${CONFIGURE_TARGET:S/amd64/x86_64/}
diff --git a/lang/pocl/pkg-plist b/lang/pocl/pkg-plist
index 5eb68042fef3..977c3d79d80c 100644
--- a/lang/pocl/pkg-plist
+++ b/lang/pocl/pkg-plist
@@ -30,3 +30,4 @@ libdata/pkgconfig/pocl.pc
%%X86%%%%DATADIR%%/kernel-%%CONFIGURE_TARGET%%-sse41.bc
%%X86%%%%DATADIR%%/kernel-%%CONFIGURE_TARGET%%-ssse3.bc
%%AARCH64%%%%DATADIR%%/kernel-%%CONFIGURE_TARGET%%-cortex-a53.bc
+%%PPC64%%%%DATADIR%%/kernel-%%CONFIGURE_TARGET%%-ppc64.bc