aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-06-19 21:20:06 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-06-20 05:18:35 +0000
commita8aa3465d570fdf904e64e73b5d027b14074a36b (patch)
tree515e5c360f050308b0dbf1d384ddfd14715f5010
parent3a6b9c0c0ad0df2750a13b52f10b94f1ec08f654 (diff)
downloadports-a8aa3465d570fdf904e64e73b5d027b14074a36b.tar.gz
ports-a8aa3465d570fdf904e64e73b5d027b14074a36b.zip
net-p2p/monero-cli: fix build on powerpc64le
c++: error: unsupported option '-maes' for target 'powerpc64le-unknown-freebsd14.1'
-rw-r--r--net-p2p/monero-cli/files/patch-CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/net-p2p/monero-cli/files/patch-CMakeLists.txt b/net-p2p/monero-cli/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a082267a06e4
--- /dev/null
+++ b/net-p2p/monero-cli/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2024-06-19 20:56:45 UTC
++++ CMakeLists.txt
+@@ -303,7 +303,7 @@ endif()
+ set(ARCH "armv8-a")
+ endif()
+
+-if(ARCH_ID STREQUAL "ppc64le")
++if(ARCH_ID STREQUAL "powerpc64le" OR ARCH_ID STREQUAL "ppc64le")
+ set(PPC64LE 1)
+ set(PPC64 0)
+ set(PPC 0)