aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2022-10-20 20:23:12 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2022-10-20 20:23:12 +0000
commita8fb74ec973ebe38b110bf232f8b1b9de219e65d (patch)
treebc264413929235dd3b87fa3a8d5b571f214b23e8
parentc9665e214f726d9a6e62af00d81b94567ebe2572 (diff)
downloadports-a8fb74ec973ebe38b110bf232f8b1b9de219e65d.tar.gz
ports-a8fb74ec973ebe38b110bf232f8b1b9de219e65d.zip
net-mgmt/ng_ipacct: Fix build on 14.0.
src commit 0f617ae48a911caab3130d0e80cfb425bc3b653b moved the prototype of in_pcblookup_local to a new header. src commit 28d0a740dd9a6 added "opt_kern_tls.h" #include to <netinet/tcp_var.h>. PR: 266556 Differential Revision: https://reviews.freebsd.org/D36546
-rw-r--r--net-mgmt/ng_ipacct/files/patch-ng__ipacct_Makefile11
-rw-r--r--net-mgmt/ng_ipacct/files/patch-ng__ipacct_ng__ipacct.c12
2 files changed, 23 insertions, 0 deletions
diff --git a/net-mgmt/ng_ipacct/files/patch-ng__ipacct_Makefile b/net-mgmt/ng_ipacct/files/patch-ng__ipacct_Makefile
new file mode 100644
index 000000000000..9efecce6d4db
--- /dev/null
+++ b/net-mgmt/ng_ipacct/files/patch-ng__ipacct_Makefile
@@ -0,0 +1,11 @@
+--- ng_ipacct/Makefile.orig 2022-09-13 09:00:08 UTC
++++ ng_ipacct/Makefile
+@@ -1,7 +1,7 @@ KMOD= ng_ipacct
+ # $Id: Makefile,v 1.4 2005/07/31 07:58:18 romanp Exp $
+
+ KMOD= ng_ipacct
+-SRCS= ng_ipacct.c opt_netgraph.h
++SRCS= ng_ipacct.c opt_netgraph.h opt_kern_tls.h
+
+ CFLAGS+= -g -I${.CURDIR}
+
diff --git a/net-mgmt/ng_ipacct/files/patch-ng__ipacct_ng__ipacct.c b/net-mgmt/ng_ipacct/files/patch-ng__ipacct_ng__ipacct.c
new file mode 100644
index 000000000000..b62bc827ebf4
--- /dev/null
+++ b/net-mgmt/ng_ipacct/files/patch-ng__ipacct_ng__ipacct.c
@@ -0,0 +1,12 @@
+--- ng_ipacct/ng_ipacct.c.orig 2022-09-13 09:05:22 UTC
++++ ng_ipacct/ng_ipacct.c
+@@ -49,6 +49,9 @@ static const char rcs_id[] =
+ #include <netinet/in_systm.h>
+ #include <netinet/in.h>
+ #include <netinet/in_pcb.h>
++#if __FreeBSD_version >= 1400039
++#include <netinet/in_pcb_var.h>
++#endif
+ #include <netinet/ip.h>
+ #include <netinet/ip_icmp.h>
+ #include <netinet/ip_var.h>