aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-18 16:20:08 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-18 17:10:29 +0000
commita95d728afd1ac6ccb6826009a8df00459d856d6e (patch)
tree38b68a1e597c8196d01c989b8fe23164f28fb06b
parentb43ef2834eff5ea9c1a7888a037be9dcbc8f29ff (diff)
downloadports-a95d728afd1ac6ccb6826009a8df00459d856d6e.tar.gz
ports-a95d728afd1ac6ccb6826009a8df00459d856d6e.zip
devel/py-aspectlib: New port: Aspect-oriented programming, monkey-patch and decorators library
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-aspectlib/Makefile24
-rw-r--r--devel/py-aspectlib/distinfo3
-rw-r--r--devel/py-aspectlib/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0d96c802863f..b375010002a6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4229,6 +4229,7 @@
SUBDIR += py-asgi-lifespan
SUBDIR += py-asn1
SUBDIR += py-asn1crypto
+ SUBDIR += py-aspectlib
SUBDIR += py-aspy.yaml
SUBDIR += py-ast-decompiler
SUBDIR += py-asteval
diff --git a/devel/py-aspectlib/Makefile b/devel/py-aspectlib/Makefile
new file mode 100644
index 000000000000..946daec0378e
--- /dev/null
+++ b/devel/py-aspectlib/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= aspectlib
+DISTVERSION= 2.0.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Aspect-oriented programming, monkey-patch and decorators library
+WWW= https://github.com/ionelmc/python-aspectlib
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= pep517 cython autoplist pytest # tests fail to start, see https://github.com/ionelmc/python-aspectlib/issues/27
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-aspectlib/distinfo b/devel/py-aspectlib/distinfo
new file mode 100644
index 000000000000..e524aaea7cb5
--- /dev/null
+++ b/devel/py-aspectlib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1687104796
+SHA256 (aspectlib-2.0.0.tar.gz) = a4b461b9da0b531aebcb93efcde3de808a72c60226dd8d902c467d13faf7ce92
+SIZE (aspectlib-2.0.0.tar.gz) = 156591
diff --git a/devel/py-aspectlib/pkg-descr b/devel/py-aspectlib/pkg-descr
new file mode 100644
index 000000000000..18d74b0edde4
--- /dev/null
+++ b/devel/py-aspectlib/pkg-descr
@@ -0,0 +1,4 @@
+aspectlib is an aspect-oriented programming, monkey-patch and decorators
+library. It is useful when changing behavior in existing code is desired.
+It includes tools for debugging and testing: simple mock/record and a
+complete capture/replay framework.