aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-25 09:03:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-25 09:03:07 +0000
commitaa469725eb9acf665d738ca24ce02730a459eddb (patch)
tree67dd707af399ea291bc2ac410a3bdba8b9a945ff
parente5c47d34d0ab3ae2ad4f0ae73093b398743a2bbc (diff)
downloadports-aa469725eb9acf665d738ca24ce02730a459eddb.tar.gz
ports-aa469725eb9acf665d738ca24ce02730a459eddb.zip
sysutils/parallel: Fix --number-of-cores
- Bump PORTREVISION for package change PR: 268011 Reported by: jwb
-rw-r--r--sysutils/parallel/Makefile1
-rw-r--r--sysutils/parallel/files/patch-src-parallel18
2 files changed, 19 insertions, 0 deletions
diff --git a/sysutils/parallel/Makefile b/sysutils/parallel/Makefile
index f909c0ad9a57..c82ffddc26e6 100644
--- a/sysutils/parallel/Makefile
+++ b/sysutils/parallel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= parallel
PORTVERSION= 20231122
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= GNU
diff --git a/sysutils/parallel/files/patch-src-parallel b/sysutils/parallel/files/patch-src-parallel
new file mode 100644
index 000000000000..b0a1e33b811b
--- /dev/null
+++ b/sysutils/parallel/files/patch-src-parallel
@@ -0,0 +1,18 @@
+--- src/parallel.orig 2023-11-23 00:27:43 UTC
++++ src/parallel
+@@ -8704,13 +8704,9 @@ sub sct_freebsd($) {
+ local $/ = "\n";
+ my $cpu = shift;
+ $cpu->{'cores'} ||=
+- (::qqx(qq{ sysctl -a dev.cpu | grep \%parent | awk '{ print \$2 }' | uniq | wc -l | awk '{ print \$1 }' })
+- or
+- ::qqx(qq{ sysctl hw.ncpu | awk '{ print \$2 }' }));
++ ::qqx(qq{ sysctl kern.smp.cores | awk '{ print \$2 }' });
+ $cpu->{'threads'} ||=
+- (::qqx(qq{ sysctl hw.ncpu | awk '{ print \$2 }' })
+- or
+- ::qqx(qq{ sysctl -a dev.cpu | grep \%parent | awk '{ print \$2 }' | uniq | wc -l | awk '{ print \$1 }' }));
++ ::qqx(qq{ sysctl kern.smp.cpus | awk '{ print \$2 }' });
+ return $cpu;
+ }
+