aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2021-05-05 11:33:01 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2021-05-05 11:33:01 +0000
commitaa4b948a4318853e8d74708fc1eec773bce06031 (patch)
tree0f589c3a56fe4936a4b2c9b2f88afdcdbc2e12f5
parenta523e531cd2418b75d43ef92f1f41adba7619fec (diff)
downloadports-aa4b948a4318853e8d74708fc1eec773bce06031.tar.gz
ports-aa4b948a4318853e8d74708fc1eec773bce06031.zip
net/td-system-info: New port
Printing basic system information and system maintenance - Submitter becomes Maintainer PR: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255576 Reported by: Thomas Dreibholz <dreibh@iem.uni-due.de> Approved by: garga (mentor) Differential Revision: https://reviews.freebsd.org/D30098
-rw-r--r--net/Makefile1
-rw-r--r--net/td-system-tools/Makefile19
-rw-r--r--net/td-system-tools/distinfo3
-rw-r--r--net/td-system-tools/pkg-descr17
-rw-r--r--net/td-system-tools/pkg-plist10
5 files changed, 50 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 16a00758c5e2..43f823c399e4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1456,6 +1456,7 @@
SUBDIR += tcpwatch
SUBDIR += tcpxd
SUBDIR += tcpxtract
+ SUBDIR += td-system-tools
SUBDIR += tdetect
SUBDIR += termshark
SUBDIR += tftpgrab
diff --git a/net/td-system-tools/Makefile b/net/td-system-tools/Makefile
new file mode 100644
index 000000000000..042a9e135559
--- /dev/null
+++ b/net/td-system-tools/Makefile
@@ -0,0 +1,19 @@
+# Created by: Thomas Dreibholz <dreibh@iem.uni-due.de>
+
+PORTNAME= td-system-tools
+PORTVERSION= 1.2.0
+CATEGORIES= net
+MASTER_SITES= https://www.uni-due.de/~be0001/system-tools/download/
+
+MAINTAINER= dreibh@iem.uni-due.de
+COMMENT= Printing basic system information and system maintenance
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= bash:shells/bash
+
+USES= cmake tar:xz
+CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR=${PREFIX}/share/man
+
+.include <bsd.port.mk>
diff --git a/net/td-system-tools/distinfo b/net/td-system-tools/distinfo
new file mode 100644
index 000000000000..29077b5aef3f
--- /dev/null
+++ b/net/td-system-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620067262
+SHA256 (td-system-tools-1.2.0.tar.xz) = 974a3d7b49d7b95f4d968aa8cf3e5e3caaf7121572aeed3e09ec52f44c975716
+SIZE (td-system-tools-1.2.0.tar.xz) = 115544
diff --git a/net/td-system-tools/pkg-descr b/net/td-system-tools/pkg-descr
new file mode 100644
index 000000000000..8ccc04b3496d
--- /dev/null
+++ b/net/td-system-tools/pkg-descr
@@ -0,0 +1,17 @@
+This package contains programs for printing basic system
+information and for system maintenance.
+System-Info displays basic status information about the
+system: hostname, uptime, CPU, memory statistics, disk
+space statistics, SSH public key hashes, and networking
+information. Furthermore, it can be configured to show
+one or more banners (for example, a project name).
+System-Info can be configured to be automatically run when
+logging in, providing the user an up-to-date overview of
+the system.
+System-Maintenance runs basic system maintenance tasks:
+trying to repair broken package management, updating the
+package management databases, installing all available
+updates, checking for old kernels and removing them, trim
+SSD or unmap unused storage.
+
+WWW: https://www.uni-due.de/~be0001/system-tools/
diff --git a/net/td-system-tools/pkg-plist b/net/td-system-tools/pkg-plist
new file mode 100644
index 000000000000..3b3b2a8bd4e1
--- /dev/null
+++ b/net/td-system-tools/pkg-plist
@@ -0,0 +1,10 @@
+bin/System-Info
+bin/System-Maintenance
+bin/configure-grub
+share/man/man1/System-Info.1.gz
+share/man/man1/System-Maintenance.1.gz
+share/man/man1/configure-grub.1.gz
+etc/system-info.d/01-example
+etc/system-maintenance.d/XX-example
+share/configure-grub/grub-defaults-nornet
+share/configure-grub/grub-defaults-standard