aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2023-03-13 09:22:43 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2023-03-13 09:22:43 +0000
commitaa4c061dc691318acfe83b71793b9a9b520cc8a9 (patch)
tree1fde9b4b7945c3a8e6fb56083200b32210685f56
parent0af04dc86b0eba06fc16fa9d3e90fca799c89a6e (diff)
downloadports-aa4c061dc691318acfe83b71793b9a9b520cc8a9.tar.gz
ports-aa4c061dc691318acfe83b71793b9a9b520cc8a9.zip
rchivers/lha: add support for DISABLE_LICENSES
PR: 270082
-rw-r--r--archivers/lha/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/archivers/lha/Makefile b/archivers/lha/Makefile
index 4deffef197ca..b18c8b01cbef 100644
--- a/archivers/lha/Makefile
+++ b/archivers/lha/Makefile
@@ -20,13 +20,17 @@ CPE_VENDOR= tsugio_okamoto
PLIST_FILES= bin/lha
PLIST_FILES+= man/ja/man1/lha.1.gz
PLIST_FILES+= share/${UNIQUE_PREFIX}${PORTNAME}/lha-114i.tar.gz
+.if !defined(DISABLE_LICENSES)
PLIST_FILES+= share/licenses/${PKGNAME}/LICENSE.en
+.endif
do-install:
-${MKDIR} ${STAGEDIR}${PREFIX}/man/ja/man1 ${STAGEDIR}${DATADIR} ${STAGEDIR}${_LICENSE_DIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/lha ${STAGEDIR}${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/man/lha.n ${STAGEDIR}${PREFIX}/man/ja/man1/lha.1
${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${STAGEDIR}${DATADIR}/
+.if !defined(DISABLE_LICENSES)
${INSTALL_DATA} ${FILESDIR}/LICENSE.en ${STAGEDIR}${_LICENSE_DIR}/
+.endif
.include <bsd.port.mk>