aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-11-08 18:14:47 +0000
committerCy Schubert <cy@FreeBSD.org>2021-11-08 18:57:51 +0000
commitaa6d4c5f4083e0de9730e323d7d94dac673dd2d1 (patch)
treeb00c94f9ffb7b49688ffd289c3da7b44a892cf8d
parent215e42f723865c7d50d38ec6373df4cff54c3f3c (diff)
downloadports-aa6d4c5f4083e0de9730e323d7d94dac673dd2d1.tar.gz
ports-aa6d4c5f4083e0de9730e323d7d94dac673dd2d1.zip
security/krb5-devel: update to the latest MIT/KRB5 github commit
-rw-r--r--security/krb5-devel/Makefile4
-rw-r--r--security/krb5-devel/distinfo6
-rw-r--r--security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.c29
-rw-r--r--security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.h13
4 files changed, 14 insertions, 38 deletions
diff --git a/security/krb5-devel/Makefile b/security/krb5-devel/Makefile
index f7cf442ce478..aaccec6b7e8b 100644
--- a/security/krb5-devel/Makefile
+++ b/security/krb5-devel/Makefile
@@ -6,8 +6,8 @@ CATEGORIES= security
.if !defined(MASTERDIR)
PKGNAMESUFFIX= -devel
.endif
-HASH= d22ed9b92
-MIT_COMMIT_DATE= 2021.10.28
+HASH= b0e74f60b
+MIT_COMMIT_DATE= 2021.11.05
PATCH_SITES= http://web.mit.edu/kerberos/advisories/
PATCH_DIST_STRIP= -p2
diff --git a/security/krb5-devel/distinfo b/security/krb5-devel/distinfo
index 41ab73cb895d..73b96cefbd06 100644
--- a/security/krb5-devel/distinfo
+++ b/security/krb5-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1635782046
-SHA256 (krb5-krb5-1.19.2021.10.28-d22ed9b92_GH0.tar.gz) = a5a6f8e51d157467ea7bbe86790f9a3065e562933f0c9999ff29596d116d4d32
-SIZE (krb5-krb5-1.19.2021.10.28-d22ed9b92_GH0.tar.gz) = 5078135
+TIMESTAMP = 1636394583
+SHA256 (krb5-krb5-1.19.2021.11.05-b0e74f60b_GH0.tar.gz) = 84eb7ed99abe1fbb4e4743a4ed4ca558dab68d9696b5de60c009c80ee1358a96
+SIZE (krb5-krb5-1.19.2021.11.05-b0e74f60b_GH0.tar.gz) = 5078486
diff --git a/security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.c b/security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.c
index bb8ac5b8d049..a26d295ebf75 100644
--- a/security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.c
+++ b/security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.c
@@ -1,6 +1,6 @@
---- plugins/preauth/pkinit/pkinit_crypto_openssl.c.orig 2019-01-08 08:02:37.000000000 -0800
-+++ plugins/preauth/pkinit/pkinit_crypto_openssl.c 2019-05-02 12:18:53.494194000 -0700
-@@ -189,7 +189,8 @@
+--- plugins/preauth/pkinit/pkinit_crypto_openssl.c.orig 2021-11-05 16:24:07.000000000 -0700
++++ plugins/preauth/pkinit/pkinit_crypto_openssl.c 2021-11-08 10:10:45.431325000 -0800
+@@ -178,7 +178,8 @@
(*_x509_pp) = PKCS7_cert_from_signer_info(_p7,_si)
#endif
@@ -10,25 +10,14 @@
/* 1.1 standardizes constructor and destructor names, renaming
* EVP_MD_CTX_{create,destroy} and deprecating ASN1_STRING_data. */
-@@ -249,6 +250,10 @@
-
- #endif
-
+@@ -722,6 +723,10 @@
+ DH_free(dh);
+ return pkey;
+ }
++
+#if defined(LIBRESSL_VERSION_NUMBER) && !defined(static_ASN1_SEQUENCE_END_name)
+#define static_ASN1_SEQUENCE_END_name ASN1_SEQUENCE_END_name
+#endif
-+
+
static struct pkcs11_errstrings {
short code;
- char *text;
-@@ -3053,7 +3058,9 @@
- return retval;
- }
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if ((defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x10100000L) && \
-+ !defined(LIBRESSL_VERSION_NUMBER)) || \
-+ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER >= 0x20900000L)
-
- /*
- * We need to decode DomainParameters from RFC 3279 section 2.3.3. We would
diff --git a/security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.h b/security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.h
deleted file mode 100644
index 0cc2e38a4f59..000000000000
--- a/security/krb5-devel/files/patch-plugins_preauth_pkinit_pkinit__crypto__openssl.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- plugins/preauth/pkinit/pkinit_crypto_openssl.h.orig 2018-11-01 23:51:07 UTC
-+++ plugins/preauth/pkinit/pkinit_crypto_openssl.h
-@@ -46,7 +46,9 @@
- #include <openssl/asn1.h>
- #include <openssl/pem.h>
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if ((defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x10100000L) && \
-+ !defined(LIBRESSL_VERSION_NUMBER)) || \
-+ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER >= 0x20900000L)
- #include <openssl/asn1t.h>
- #else
- #include <openssl/asn1_mac.h>