aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-31 03:27:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-31 03:51:04 +0000
commitaa7a64ae1bd61ed2bdc97df1d662f104bcb31ce5 (patch)
tree4fff7081b0f6889ecf7fd6f1a851e15ee9edcf4e
parent5568d24ec818ea6ade5eab4bb49175c7b8fc4e75 (diff)
downloadports-aa7a64ae1bd61ed2bdc97df1d662f104bcb31ce5.tar.gz
ports-aa7a64ae1bd61ed2bdc97df1d662f104bcb31ce5.zip
audio/umurmur: Jettison byteswap/endian hacks
-rw-r--r--audio/umurmur/Makefile3
-rw-r--r--audio/umurmur/files/patch-configure.ac8
-rw-r--r--audio/umurmur/files/patch-src_conf.c4
-rw-r--r--audio/umurmur/patch-src_byteorder.h (renamed from audio/umurmur/files/patch-src_byteorder.h)9
4 files changed, 9 insertions, 15 deletions
diff --git a/audio/umurmur/Makefile b/audio/umurmur/Makefile
index c7ab80fceb03..bed7bc05b9d1 100644
--- a/audio/umurmur/Makefile
+++ b/audio/umurmur/Makefile
@@ -9,9 +9,6 @@ WWW= https://umurmur.net/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_aarch64= fails to compile: fatal error: byteswap.h file not found
-BROKEN_armv6= fails to compile: fatal error: byteswap.h file not found
-
LIB_DEPENDS= libconfig.so:devel/libconfig \
libprotobuf-c.so:devel/protobuf-c
diff --git a/audio/umurmur/files/patch-configure.ac b/audio/umurmur/files/patch-configure.ac
index 14045b5e9d7b..6e9a84ad3b72 100644
--- a/audio/umurmur/files/patch-configure.ac
+++ b/audio/umurmur/files/patch-configure.ac
@@ -1,8 +1,8 @@
---- configure.ac.orig 2015-04-07 10:01:12 UTC
+--- configure.ac.orig 2021-03-21 20:49:04 UTC
+++ configure.ac
-@@ -113,7 +113,7 @@ AS_IF([test "x$enable_shmapi" != xno],
-
-
+@@ -118,7 +118,7 @@ AS_IF([test "x$enable_shmapi" != xno],
+ AM_CONDITIONAL(USE_SHAREDMEMORY_API, false)
+ ])
-AC_DEFINE([DEFAULT_CONFIG], ["/etc/umurmur.conf"], [Default config])
+AC_DEFINE([DEFAULT_CONFIG], ["%%PREFIX%%/etc/umurmur.conf"], [Default config])
diff --git a/audio/umurmur/files/patch-src_conf.c b/audio/umurmur/files/patch-src_conf.c
index 209de220eae0..ab4b7b3df91e 100644
--- a/audio/umurmur/files/patch-src_conf.c
+++ b/audio/umurmur/files/patch-src_conf.c
@@ -1,6 +1,6 @@
---- src/conf.c.orig 2015-04-07 10:01:12 UTC
+--- src/conf.c.orig 2021-03-21 20:49:04 UTC
+++ src/conf.c
-@@ -89,23 +89,23 @@ const char *getStrConf(param_t param)
+@@ -90,23 +90,23 @@ const char *getStrConf(param_t param)
case CERTIFICATE:
setting = config_lookup(&configuration, "certificate");
if (!setting)
diff --git a/audio/umurmur/files/patch-src_byteorder.h b/audio/umurmur/patch-src_byteorder.h
index 05b7a4e5863a..134ce96050d4 100644
--- a/audio/umurmur/files/patch-src_byteorder.h
+++ b/audio/umurmur/patch-src_byteorder.h
@@ -1,16 +1,13 @@
---- src/byteorder.h.orig 2020-10-20 00:54:48 UTC
+--- src/byteorder.h.orig 2021-03-21 20:49:04 UTC
+++ src/byteorder.h
-@@ -56,8 +56,12 @@ typedef uint64_t subblock;
+@@ -56,8 +56,10 @@ typedef uint64_t subblock;
#elif defined( __x86_64__)
#define SWAPPED(x) ({register uint64_t __out, __in = (x); __asm__("bswap %q0" : "=r"(__out) : "0"(__in)); __out;})
#else
+#if defined(__linux__)
#include <byteswap.h>
--#define SWAPPED(x) bswap_64(x)
-+#elif defined(__FreeBSD__)
-+#include <sys/endian.h>
+ #define SWAPPED(x) bswap_64(x)
+#endif // defined(__linux__)
-+#define SWAPPED(x) bswap64(x)
#endif // defined(BYTE_ORDER_BIG_ENDIAN)
#else
#define BLOCKSIZE 4