aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-06-28 17:23:18 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-06-28 17:24:24 +0000
commitaadf6428cc480fbeda72ec90d53ef340e95f49ca (patch)
treef8125033078b999f8a7dee2db9929cec67a994f7
parent05ec3ef06b57fe5067220539d92f74828913bb7f (diff)
downloadports-aadf6428cc480fbeda72ec90d53ef340e95f49ca.tar.gz
ports-aadf6428cc480fbeda72ec90d53ef340e95f49ca.zip
lang/gcc11: disable LTO on armv6/7
PR: 261977
-rw-r--r--lang/gcc11/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/lang/gcc11/Makefile b/lang/gcc11/Makefile
index 87f72649f377..350d5983a9c6 100644
--- a/lang/gcc11/Makefile
+++ b/lang/gcc11/Makefile
@@ -36,10 +36,18 @@ SUFFIX= ${PORTVERSION:C/([0-9]+).*/\1/}
CFLAGS:= ${CFLAGS:N-mretpoline}
CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
-OPTIONS_DEFINE= BOOTSTRAP GRAPHITE
-OPTIONS_DEFAULT= BOOTSTRAP
-BOOTSTRAP_DESC= Build using a full bootstrap
+OPTIONS_DEFINE= GRAPHITE
GRAPHITE_DESC= Support for Graphite loop optimizations
+OPTIONS_DEFAULT_aarch64=LTO_BOOTSTRAP
+OPTIONS_DEFAULT_amd64= LTO_BOOTSTRAP
+OPTIONS_DEFAULT_i386= LTO_BOOTSTRAP
+OPTIONS_DEFAULT_powerpc=LTO_BOOTSTRAP
+OPTIONS_DEFAULT_powerpc64=LTO_BOOTSTRAP
+OPTIONS_DEFAULT_powerpc64le=LTO_BOOTSTRAP
+OPTIONS_RADIO= BOOTSTRAP
+OPTIONS_RADIO_BOOTSTRAP= LTO_BOOTSTRAP STANDARD_BOOTSTRAP
+LTO_BOOTSTRAP_DESC= Build using a full LTO bootstrap
+STANDARD_BOOTSTRAP_DESC= Build using a full bootstrap without LTO
.if exists(/usr/lib32/libc.so)
OPTIONS_DEFINE_amd64+= MULTILIB
@@ -67,11 +75,14 @@ TARGLIB32= ${PREFIX}/lib32 # The version information is added later
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
-.if empty(PORT_OPTIONS:MBOOTSTRAP)
+.if empty(PORT_OPTIONS:M*BOOTSTRAP)
CONFIGURE_ARGS+=--disable-bootstrap
-.else
+.elif ${PORT_OPTIONS:MLTO_BOOTSTRAP}
CONFIGURE_ARGS+=--with-build-config=bootstrap-lto-noplugin
ALL_TARGET= bootstrap-lean
+.else
+CONFIGURE_ARGS+=--with-build-config=bootstrap-debug
+ALL_TARGET= bootstrap-lean
.endif
INSTALL_TARGET= install-strip
.if ${UID} != 0