aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2023-11-29 13:48:16 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2023-11-29 13:52:36 +0000
commitab5f2419c25ed3fc110694bba67c8e07a743216a (patch)
tree86a78cac36e82999f3676a51b051a96187a3a7d8
parentb92aabc8864e7e086db4271b193578784b4d1ff3 (diff)
downloadports-ab5f2419c25ed3fc110694bba67c8e07a743216a.tar.gz
ports-ab5f2419c25ed3fc110694bba67c8e07a743216a.zip
x11/xwayland-run: Add new port
xwayland-run contains a set of small utilities revolving around running Xwayland and various Wayland compositor headless. Sponsored by: Beckhoff Automation GmbH & Co. KG
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xwayland-run/Makefile27
-rw-r--r--x11/xwayland-run/distinfo3
-rw-r--r--x11/xwayland-run/pkg-descr2
-rw-r--r--x11/xwayland-run/pkg-plist14
5 files changed, 47 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 8dbec9ef64df..4fb52d5784ef 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -621,6 +621,7 @@
SUBDIR += xvt
SUBDIR += xwatchwin
SUBDIR += xwaylandvideobridge
+ SUBDIR += xwayland-run
SUBDIR += xwd
SUBDIR += xwininfo
SUBDIR += xwinwrap
diff --git a/x11/xwayland-run/Makefile b/x11/xwayland-run/Makefile
new file mode 100644
index 000000000000..24561c48f584
--- /dev/null
+++ b/x11/xwayland-run/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= xwayland-run
+PORTVERSION= 0.0.2
+CATEGORIES= x11
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= Run Xwayland and compositor headless
+WWW= https://gitlab.freedesktop.org/ofourdan/xwayland-run
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= cage>0:x11-wm/cage
+
+USES= meson pkgconfig python shebangfix tar:xz
+
+USE_GITLAB= yes
+GL_SITE= https://gitlab.freedesktop.org
+GL_ACCOUNT= ofourdan
+
+BINARY_ALIAS+= python3=${PYTHON_VERSION}
+SHEBANG_FILES= src/xwfb-run.py \
+ src/xwayland-run.py \
+ src/wlheadless-run.py
+
+MESON_ARGS= -Dcompositor=cage
+
+.include <bsd.port.mk>
diff --git a/x11/xwayland-run/distinfo b/x11/xwayland-run/distinfo
new file mode 100644
index 000000000000..6cf768a6101e
--- /dev/null
+++ b/x11/xwayland-run/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1701264706
+SHA256 (xwayland-run-0.0.2.tar.bz2) = 21a97a983af0e31fecf6cffc9528c194b7a8cdba11428efd2b8ed5a3edfcb183
+SIZE (xwayland-run-0.0.2.tar.bz2) = 15366
diff --git a/x11/xwayland-run/pkg-descr b/x11/xwayland-run/pkg-descr
new file mode 100644
index 000000000000..c6de1e69ca10
--- /dev/null
+++ b/x11/xwayland-run/pkg-descr
@@ -0,0 +1,2 @@
+xwayland-run contains a set of small utilities revolving around running
+Xwayland and various Wayland compositor headless.
diff --git a/x11/xwayland-run/pkg-plist b/x11/xwayland-run/pkg-plist
new file mode 100644
index 000000000000..91f84f1702b9
--- /dev/null
+++ b/x11/xwayland-run/pkg-plist
@@ -0,0 +1,14 @@
+bin/wlheadless-run
+bin/xwayland-run
+bin/xwfb-run
+%%PYTHON_SITELIBDIR%%/wlheadless/__init__.py
+%%PYTHON_SITELIBDIR%%/wlheadless/cage.py
+%%PYTHON_SITELIBDIR%%/wlheadless/gnome-kiosk.py
+%%PYTHON_SITELIBDIR%%/wlheadless/mutter.py
+%%PYTHON_SITELIBDIR%%/wlheadless/weston.py
+%%PYTHON_SITELIBDIR%%/wlheadless/wlheadless_common.py
+%%PYTHON_SITELIBDIR%%/wlheadless/xwayland.py
+man/man1/wlheadless-run.1.gz
+man/man1/xwayland-run.1.gz
+man/man1/xwfb-run.1.gz
+share/wlheadless/wlheadless.conf