aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-24 23:49:25 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 18:09:47 +0000
commitabad80143b961d4b2431114a4a5160d0efd04284 (patch)
tree304afaaa7350dd5c6c6db151b97316aeeb4b1bf9
parent3a8cd0d0c825b5d685468281e699b421b51e66e9 (diff)
downloadports-abad80143b961d4b2431114a4a5160d0efd04284.tar.gz
ports-abad80143b961d4b2431114a4a5160d0efd04284.zip
x11-toolkits/fox16: Fix build with llvm16
- Utilize USES=localbase Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--x11-toolkits/fox16/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-toolkits/fox16/Makefile b/x11-toolkits/fox16/Makefile
index 24819db2fb4f..ab05351f6a92 100644
--- a/x11-toolkits/fox16/Makefile
+++ b/x11-toolkits/fox16/Makefile
@@ -16,15 +16,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USES= compiler:features gl jpeg libtool pathfix xorg
+USES= compiler:features gl jpeg libtool localbase:ldflags pathfix xorg
USE_GL= gl glu
USE_XORG= x11 xext xfixes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-opengl --with-x --with-xim
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include -fPIC
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -fPIC
PLIST_SUB= MAJORVER="${MAJORVER}"
@@ -84,6 +83,10 @@ CXXFLAGS+= -fexpensive-optimizations -finline-functions
. endif
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CPPFLAGS+= -Dregister=
+.endif
+
post-patch:
# Rename man pages as in manpage.1 --> manpage-16.1 to avoid
# conflicts with fox14 and fox17