aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGasol Wu <gasol.wu@gmail.com>2022-01-05 07:56:02 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-05 07:58:40 +0000
commitabbdd562d85f30900450f23cf52283b92bcb3792 (patch)
tree7ca45618fd8b04c03aea822b6a448e0d569a6be7
parent296c8b3307ee768a73d7e00f5b63afa82a0e2c37 (diff)
downloadports-abbdd562d85f30900450f23cf52283b92bcb3792.tar.gz
ports-abbdd562d85f30900450f23cf52283b92bcb3792.zip
textproc/php-mecab: Add support for php74
- Pet portlint PR: 260654 Approved by: gasol.wu@gmail.com
-rw-r--r--textproc/php-mecab/Makefile6
-rw-r--r--textproc/php-mecab/files/patch-mecab7.c11
2 files changed, 14 insertions, 3 deletions
diff --git a/textproc/php-mecab/Makefile b/textproc/php-mecab/Makefile
index 16dc343e608c..8c3ef5e2bbe5 100644
--- a/textproc/php-mecab/Makefile
+++ b/textproc/php-mecab/Makefile
@@ -2,8 +2,8 @@
PORTNAME= mecab
PORTVERSION= 0.6.0
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= textproc
PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
@@ -14,13 +14,13 @@ LICENSE= MIT
LIB_DEPENDS= libmecab.so:japanese/mecab
+IGNORE_WITH_PHP= 80
+USES= php:ext
USE_GITHUB= yes
GH_ACCOUNT= rsky
GH_PROJECT= php-${PORTNAME}
WRKSRC_SUBDIR= mecab
CONFIGURE_ARGS= --with-mecab=${LOCALBASE}/bin/mecab-config
-USES= php:ext
-IGNORE_WITH_PHP= 74 80
.include <bsd.port.mk>
diff --git a/textproc/php-mecab/files/patch-mecab7.c b/textproc/php-mecab/files/patch-mecab7.c
new file mode 100644
index 000000000000..8e58ce50ad35
--- /dev/null
+++ b/textproc/php-mecab/files/patch-mecab7.c
@@ -0,0 +1,11 @@
+--- mecab7.c.orig 2015-12-05 16:08:55 UTC
++++ mecab7.c
+@@ -1456,7 +1456,7 @@ static PHP_FUNCTION(mecab_new)
+ if (zoptions != NULL) {
+ int getopt_result = 0;
+ zend_string *key;
+- ulong num_key;
++ zend_ulong num_key;
+ zval *entry;
+
+ ALLOC_HASHTABLE(options);