aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 13:42:17 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 14:46:34 +0000
commitabe6905109ab2140c698966e1bd823d25147bbb5 (patch)
treef68665fcdb927feccea56239566912981409058d
parent8f3f52224f8f491e627b643d098caa0549ca09ef (diff)
downloadports-abe6905109ab2140c698966e1bd823d25147bbb5.tar.gz
ports-abe6905109ab2140c698966e1bd823d25147bbb5.zip
games/odamex: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--games/odamex/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/odamex/Makefile b/games/odamex/Makefile
index 7c09fd894206..259d85c85cbd 100644
--- a/games/odamex/Makefile
+++ b/games/odamex/Makefile
@@ -14,19 +14,19 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpng.so:graphics/png
-USE_SDL= sdl mixer
USES= cmake:insource compiler dos2unix sdl tar:bzip2
DOS2UNIX_FILES= CMakeLists.txt odalaunch/CMakeLists.txt common/d_main.cpp
+USE_CXXSTD= c++14
+USE_SDL= sdl mixer
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
CXXFLAGS_clang= -Wno-c++11-narrowing
OPTIONS_DEFINE= DOCS LAUNCHER
+OPTIONS_SUB= yes
LAUNCHER_DESC= Enable GUI launcher program
-OPTIONS_SUB= yes
-
LAUNCHER_USE= WX=3.0
LAUNCHER_CMAKE_ON= -DODALAUNCH_TARGET=on -DNO_AG-ODALAUNCH_TARGET=off -DwxWidgets_CONFIG_EXECUTABLE=${PREFIX}/bin/wxgtk2u-3.0-config
LAUNCHER_CMAKE_OFF= -DODALAUNCH_TARGET=off