aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-29 05:32:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-29 05:33:24 +0000
commitac0d262392a0d3175881eba4f19e47c30c9b9886 (patch)
tree143f9cf4bf14a2ccf99908f16a36da7d838faedc
parent3300bf124cb2c160729141eab0d1a6e9ed23c18c (diff)
downloadports-ac0d262392a0d3175881eba4f19e47c30c9b9886.tar.gz
ports-ac0d262392a0d3175881eba4f19e47c30c9b9886.zip
math/py-pytanque: New port: Petanque static python bindings
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pytanque/Makefile15
-rw-r--r--math/py-pytanque/distinfo3
-rw-r--r--math/py-pytanque/files/patch-setup.py16
-rw-r--r--math/py-pytanque/pkg-descr4
5 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bc7e1deff7f0..a5c3c9072703 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -895,6 +895,7 @@
SUBDIR += py-pysmt
SUBDIR += py-pystan
SUBDIR += py-pysym
+ SUBDIR += py-pytanque
SUBDIR += py-python-fcl
SUBDIR += py-python-igraph
SUBDIR += py-python-louvain
diff --git a/math/py-pytanque/Makefile b/math/py-pytanque/Makefile
new file mode 100644
index 000000000000..3f26c47d212b
--- /dev/null
+++ b/math/py-pytanque/Makefile
@@ -0,0 +1,15 @@
+PORTNAME= pytanque
+DISTVERSION= 1.1.0
+CATEGORIES= math
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Petanque static python bindings
+
+LICENSE= BSD3CLAUSE
+
+USES= compiler:c++14-lang python:3.6+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/math/py-pytanque/distinfo b/math/py-pytanque/distinfo
new file mode 100644
index 000000000000..88643b6b6b24
--- /dev/null
+++ b/math/py-pytanque/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632892777
+SHA256 (pytanque-1.1.0.tar.gz) = 9365ab2038306508b673a46bed7f5425cc096d2763810f7801395a517d524cc4
+SIZE (pytanque-1.1.0.tar.gz) = 695935
diff --git a/math/py-pytanque/files/patch-setup.py b/math/py-pytanque/files/patch-setup.py
new file mode 100644
index 000000000000..b3f749f6ad8c
--- /dev/null
+++ b/math/py-pytanque/files/patch-setup.py
@@ -0,0 +1,16 @@
+--- setup.py.orig 2021-09-29 05:21:08 UTC
++++ setup.py
+@@ -3,11 +3,11 @@ import glob
+ import platform
+ import subprocess
+
+-if platform.system() in ("Linux","Darwin"):
++if platform.system() in ("Linux","Darwin","FreeBSD"):
+ # This will work w/ GCC and clang
+ compile_args = ['-std=c++14','-flto','-Dpetanque_STATIC']
+ link_args = ['-flto']
+- if platform.system() == "Linux":
++ if platform.system() == "Linux" or platform.system() == "FreeBSD":
+ link_args = ["-Wl,--strip-all","-Wl,-gc-sections"]
+ elif platform.system() == "Windows":
+ compile_args = ['/Dpetanque_STATIC','/TP', '/EHsc']
diff --git a/math/py-pytanque/pkg-descr b/math/py-pytanque/pkg-descr
new file mode 100644
index 000000000000..637cff268e84
--- /dev/null
+++ b/math/py-pytanque/pkg-descr
@@ -0,0 +1,4 @@
+Python binding for petanque, a library that helps manipulate symbolic boolean
+expressions.
+
+WWW: https://github.com/quarkslab/arybo/tree/master/petanque