aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:08:08 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:08:08 +0000
commitac20dcc847221768851cacf4c29b0329508c1a30 (patch)
treea909e59177257992c9f266f3f083a0c55454ddcd
parent15e0311fd49a424353a988df9cd4c6400333dd1c (diff)
downloadports-ac20dcc847221768851cacf4c29b0329508c1a30.tar.gz
ports-ac20dcc847221768851cacf4c29b0329508c1a30.zip
security/py-python-pkcs11: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--security/py-python-pkcs11/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/py-python-pkcs11/Makefile b/security/py-python-pkcs11/Makefile
index 9305fe64201c..de79ce0ba106 100644
--- a/security/py-python-pkcs11/Makefile
+++ b/security/py-python-pkcs11/Makefile
@@ -1,5 +1,6 @@
PORTNAME= python-pkcs11
PORTVERSION= 0.7.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,11 +11,13 @@ WWW= https://github.com/danni/python-pkcs11
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=0:devel/py-asn1crypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cached-property>=0:devel/py-cached-property@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent cython distutils
+USE_PYTHON= autoplist concurrent cython pep517
.include <bsd.port.mk>