aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:45:18 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:00 +0000
commitacc3d16d56d0e5d225a13a2982095a86ac3fb577 (patch)
tree7c8f38b382f39de40441019355e26e9e844352b5
parentbe3e572e8113171b028e459608f28b95aae54fc9 (diff)
downloadports-acc3d16d56d0e5d225a13a2982095a86ac3fb577.tar.gz
ports-acc3d16d56d0e5d225a13a2982095a86ac3fb577.zip
devel/py-pytest-enabler: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-pytest-enabler/Makefile10
-rw-r--r--devel/py-pytest-enabler/files/setup.py3
2 files changed, 5 insertions, 8 deletions
diff --git a/devel/py-pytest-enabler/Makefile b/devel/py-pytest-enabler/Makefile
index a70d7c882e20..65e9a81c228d 100644
--- a/devel/py-pytest-enabler/Makefile
+++ b/devel/py-pytest-enabler/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pytest-enabler
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +12,9 @@ WWW= https://github.com/jaraco/pytest-enabler
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco.context>=0:devel/py-jaraco.context@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jaraco.functools>=0:devel/py-jaraco.functools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR}
@@ -23,11 +26,8 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-black>=0.3.7:devel/py-pytest-black@$
${PYTHON_PKGNAMEPREFIX}types-toml>=0:devel/py-types-toml@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.mk>
diff --git a/devel/py-pytest-enabler/files/setup.py b/devel/py-pytest-enabler/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-pytest-enabler/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()