aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-08-26 08:52:51 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-08-26 09:03:31 +0000
commitacf5d2725a4e221a2aceb44297e151dc3902735d (patch)
tree52be5dced89241a469c9bf10efb36ef9497ad68f
parent9de810561899dde848ba00fc6527b35725e0474a (diff)
downloadports-acf5d2725a4e221a2aceb44297e151dc3902735d.tar.gz
ports-acf5d2725a4e221a2aceb44297e151dc3902735d.zip
CONFLICTS_INSTALL: check later for conflicts
Until now, the check of the CONFLICTS_INSTALL was done during the sanity check, meaning very early in the package building process. this makes it painful in 2 cases: 1. a port depend at build time on the extraction of this port, it will print its warning message along with the default timer, while we will never reach the said conflict at all. 2. since the ports tree has been staged, one can even go up to create a valid package even if a locally conflicting package is locally installed. This change make the check and print of the conflicts only happen during the install phase, the same way the ports tree checks if a previous version is already installed. PR: 213890 Discussed with: tcberner Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D36355
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0ded60991a2f..9fbf900609d2 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5233,7 +5233,7 @@ _SANITY_SEQ= 050:post-chroot 100:pre-everything \
210:show-dev-errors 220:show-dev-warnings \
250:check-categories 300:check-makevars \
350:check-desktop-entries 400:check-depends \
- 450:identify-install-conflicts 500:check-deprecated \
+ 500:check-deprecated \
550:check-vulnerable 600:check-license 650:check-config \
700:buildanyway-message 750:options-message ${_USES_sanity}
@@ -5293,6 +5293,7 @@ _TEST_SEQ= 100:test-message 150:test-depends 300:pre-test 500:do-test \
${_OPTIONS_test} ${_USES_test}
_INSTALL_DEP= stage
_INSTALL_SEQ= 100:install-message \
+ 150:identify-install-conflicts \
200:check-already-installed \
300:create-manifest
_INSTALL_SUSEQ= 400:fake-pkg 500:security-check