aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-30 18:58:06 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-30 19:00:08 +0000
commitad0afe0769e845486e267fdb5d21fccf23535215 (patch)
tree1ace540fa65adb6a6c1d152795158b3042033066
parent6eefc70221d5ac26096ebf9b69c59ed8226799b3 (diff)
downloadports-ad0afe0769e845486e267fdb5d21fccf23535215.tar.gz
ports-ad0afe0769e845486e267fdb5d21fccf23535215.zip
science/*: Fix USES=octave for some ports
In my previous commits of USES=octave conversion I missed two ports in science category. Fix those to use USES=octave:env. Approved by: portmgr (blanket infrastructure)
-rw-r--r--science/cantera/Makefile2
-rw-r--r--science/h5utils/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/science/cantera/Makefile b/science/cantera/Makefile
index 97f903f18e9b..26c37e182566 100644
--- a/science/cantera/Makefile
+++ b/science/cantera/Makefile
@@ -47,7 +47,7 @@ OCTAVE_MAKE_ARGS= matlab_toolbox=y matlab_path=${LOCALBASE}
OCTAVE_CXXFLAGS= -I${LOCALBASE}/include/octave-${OCTAVE_VERSION}/octave
OCTAVE_LIB_DEPENDS= liboctave.so:math/octave
OCTAVE_SUB_FILES= pkg-message-octave
-.include "../../math/octave/Makefile.version" # for OCTAVE_VERSION
+OCTAVE_USES= octave:env
PYTHON_USES= python:3.6+
PYTHON_USE= PYTHON=cython
diff --git a/science/h5utils/Makefile b/science/h5utils/Makefile
index a32d97be6151..f16be1fa8a85 100644
--- a/science/h5utils/Makefile
+++ b/science/h5utils/Makefile
@@ -30,10 +30,10 @@ OPTIONS_SUB= yes
OCTAVE_DESC= With Octave support
OCTAVE_CONFIGURE_WITH= octave
OCTAVE_BUILD_DEPENDS= ${LOCALBASE}/include/octave-${OCTAVE_VERSION}/octave/octave.h:math/octave
+OCTAVE_USES= octave:env
OCTAVE_VARS= PLIST_SUB+="OCTAVE_VERSION=${OCTAVE_VERSION} CONFIGURE_TARGET=${CONFIGURE_TARGET}"
post-install-OCTAVE-on:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/octave/${OCTAVE_VERSION}/site/oct/${CONFIGURE_TARGET}/h5read.oct
-.include "../../math/octave/Makefile.version"
.include <bsd.port.mk>