aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-03-30 01:44:17 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-03-30 02:11:56 +0000
commitad7b9ebc5f83b064500f77dd42420fe8f9819c9b (patch)
treed70af58a55e0bc0713a216bebd670ff63bede261
parent9f340e36d30d93f8f4c829aef17381956b6ee39d (diff)
downloadports-ad7b9ebc5f83b064500f77dd42420fe8f9819c9b.tar.gz
ports-ad7b9ebc5f83b064500f77dd42420fe8f9819c9b.zip
multimedia/gstreamer1-vaapi: unbreak with --auto-features=enabled
meson.build:93:0: ERROR: Dependency "libudev" not found, tried pkgconfig meson.build:120:0: ERROR: Dependency "gtk+-3.0" not found, tried pkgconfig docs/meson.build:42:0: ERROR: Program 'hotdoc' not found or not executable PR: 270361 Reported by: antoine (via exp-run)
-rw-r--r--multimedia/gstreamer1-vaapi/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/multimedia/gstreamer1-vaapi/Makefile b/multimedia/gstreamer1-vaapi/Makefile
index 838e77bbd188..12a636f28f03 100644
--- a/multimedia/gstreamer1-vaapi/Makefile
+++ b/multimedia/gstreamer1-vaapi/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gstreamer1-vaapi
PORTVERSION= 1.22.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= https://gstreamer.freedesktop.org/src/gstreamer-vaapi/
DISTNAME= gstreamer-vaapi-${PORTVERSION}
@@ -19,19 +20,22 @@ USE_GNOME= glib20
USE_GSTREAMER= bad
USE_GL= gl
USE_XORG= x11 xrandr xrender xorgproto
+MESON_ARGS= -Ddoc=disabled -Dexamples=disabled
BINARY_ALIAS= python3=${PYTHON_VERSION}
OPTIONS_DEFINE= DRM WAYLAND
+OPTIONS_DEFAULT=DRM WAYLAND
-DRM_DESC= Raw KMS/DRM backend
+DRM_DESC= KMS console and headless support
+DRM_BUILD_DEPENDS= libdrm>0:graphics/libdrm
+DRM_LIB_DEPENDS= libudev.so:devel/libudev-devd
+DRM_MESON_ENABLED= drm
-DRM_MESON_BOOL= drm
-DRM_LIB_DEPENDS=libudev.so:devel/libudev-devd \
- libdrm.so:graphics/libdrm
-
-WAYLAND_MESON_BOOL= wayland
+WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.15:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libva-wayland.so:multimedia/libva \
libwayland-client.so:graphics/wayland
+WAYLAND_MESON_ENABLED= wayland
+WAYLAND_IMPLIES= DRM
.include <bsd.port.mk>