aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-16 13:47:34 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-16 15:25:56 +0000
commitaebf1537099aaf0fdd63c92a3559a0838e487c58 (patch)
tree9848a0e2036fa3f5adab9a785058627f4ece47f6
parent22eac850f2e1430a136d5493010f542e7203355d (diff)
downloadports-aebf1537099aaf0fdd63c92a3559a0838e487c58.tar.gz
ports-aebf1537099aaf0fdd63c92a3559a0838e487c58.zip
x11/waybar: update to 0.9.8
Changes: https://github.com/Alexays/Waybar/releases/tag/0.9.8 Reported by: GitHub (watch releases)
-rw-r--r--x11/waybar/Makefile16
-rw-r--r--x11/waybar/distinfo6
-rw-r--r--x11/waybar/files/date.pc.in2
-rw-r--r--x11/waybar/files/patch-libfmt28
4 files changed, 15 insertions, 37 deletions
diff --git a/x11/waybar/Makefile b/x11/waybar/Makefile
index 19c82d068d14..f0e82c970359 100644
--- a/x11/waybar/Makefile
+++ b/x11/waybar/Makefile
@@ -1,6 +1,5 @@
PORTNAME= waybar
-DISTVERSION= 0.9.7
-PORTREVISION= 1
+DISTVERSION= 0.9.8
CATEGORIES= x11
MAINTAINER= jbeich@FreeBSD.org
@@ -14,7 +13,8 @@ LIB_DEPENDS= libdate-tz.so:devel/date \
libjsoncpp.so:devel/jsoncpp \
libfmt.so:devel/libfmt \
libspdlog.so:devel/spdlog \
- libwayland-client.so:graphics/wayland
+ libwayland-client.so:graphics/wayland \
+ libxkbregistry.so:x11/libxkbcommon
USES= compiler:c++17-lang gnome meson pkgconfig
USE_GITHUB= yes
@@ -32,12 +32,17 @@ CONFIGURE_ENV+= PKG_CONFIG_PATH="${WRKDIR}"
SUB_FILES+= date.pc
.endif
-OPTIONS_DEFINE= DBUS GLS ICONSFONT MANPAGES MPD PULSEAUDIO SNDIO UDEV
-OPTIONS_DEFAULT=DBUS GLS ICONSFONT MANPAGES MPD PULSEAUDIO SNDIO UDEV
+OPTIONS_DEFINE= DBUS EVDEV GLS ICONSFONT MANPAGES MPD PULSEAUDIO SNDIO UDEV
+OPTIONS_DEFAULT=DBUS EVDEV GLS ICONSFONT MANPAGES MPD PULSEAUDIO SNDIO UDEV
DBUS_LIB_DEPENDS= libdbusmenu-gtk3.so:devel/libdbusmenu
DBUS_MESON_ENABLED= dbusmenu-gtk
+EVDEV_DESC= Keyboard state via libevdev
+EVDEV_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto
+EVDEV_LIB_DEPENDS= libevdev.so:devel/libevdev
+EVDEV_MESON_ENABLED= libevdev
+
GLS_DESC= Use gtk-layer-shell library for popups support
GLS_LIB_DEPENDS= libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
GLS_MESON_ENABLED= gtk-layer-shell
@@ -55,6 +60,7 @@ MANPAGES_PLIST_FILES= man/man5/${PORTNAME}-backlight.5.gz \
man/man5/${PORTNAME}-custom.5.gz \
man/man5/${PORTNAME}-disk.5.gz \
man/man5/${PORTNAME}-idle-inhibitor.5.gz \
+ man/man5/${PORTNAME}-keyboard-state.5.gz \
man/man5/${PORTNAME}-memory.5.gz \
man/man5/${PORTNAME}-mpd.5.gz \
man/man5/${PORTNAME}-network.5.gz \
diff --git a/x11/waybar/distinfo b/x11/waybar/distinfo
index 94f5269468a5..13c7b1ea3a86 100644
--- a/x11/waybar/distinfo
+++ b/x11/waybar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1618514274
-SHA256 (Alexays-Waybar-0.9.7_GH0.tar.gz) = 0d23573e0f6ce6e3f3eb4d1d7313848b924429268f3becd81649a391ae7703e7
-SIZE (Alexays-Waybar-0.9.7_GH0.tar.gz) = 150768
+TIMESTAMP = 1629121654
+SHA256 (Alexays-Waybar-0.9.8_GH0.tar.gz) = 3f067c484aaee3e7d8ded382e72c280a92913b0c4e8a20d0ac9afdf8baf19405
+SIZE (Alexays-Waybar-0.9.8_GH0.tar.gz) = 158869
diff --git a/x11/waybar/files/date.pc.in b/x11/waybar/files/date.pc.in
index a0bd9279cb1d..49d9db58bc26 100644
--- a/x11/waybar/files/date.pc.in
+++ b/x11/waybar/files/date.pc.in
@@ -5,6 +5,6 @@ includedir=${prefix}/include
Name: date
Description: Date and time library based on the C++11/14/17 <chrono> header
-Version: 3.0.0
+Version: 3.0.1
Cflags: -I${includedir}
Libs: -L${libdir} -ldate-tz
diff --git a/x11/waybar/files/patch-libfmt b/x11/waybar/files/patch-libfmt
deleted file mode 100644
index f80a7cd6cf9a..000000000000
--- a/x11/waybar/files/patch-libfmt
+++ /dev/null
@@ -1,28 +0,0 @@
-Obtained from: https://github.com/Alexays/Waybar/commit/1c2e0083ba5a80d0f22a14d2baa8df52024a7394
-
---- include/util/format.hpp.orig 2021-04-15 19:17:54 UTC
-+++ include/util/format.hpp
-@@ -35,7 +35,11 @@ namespace fmt {
- // The rationale for ignoring it is that the only reason to specify
- // an alignment and a with is to get a fixed width bar, and ">" is
- // sufficient in this implementation.
-+#if FMT_VERSION < 80000
- width = parse_nonnegative_int(it, end, ctx);
-+#else
-+ width = detail::parse_nonnegative_int(it, end, -1);
-+#endif
- }
- return it;
- }
---- src/modules/clock.cpp.orig 2021-04-15 19:17:54 UTC
-+++ src/modules/clock.cpp
-@@ -196,6 +196,9 @@ template <>
- struct fmt::formatter<waybar_time> : fmt::formatter<std::tm> {
- template <typename FormatContext>
- auto format(const waybar_time& t, FormatContext& ctx) {
-+#if FMT_VERSION >= 80000
-+ auto& tm_format = specs;
-+#endif
- return format_to(ctx.out(), "{}", date::format(t.locale, fmt::to_string(tm_format), t.ztime));
- }
- };