aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2022-05-15 22:32:06 +0000
committerJason Helfman <jgh@FreeBSD.org>2022-05-15 22:32:06 +0000
commitaf4790a6153996202e85cba64aa9a222fcc62259 (patch)
treec6c2e0c8ee5244177c8125e2637a265e1581e702
parent5504836be33de468e2a2946fd5e71667dedc2d02 (diff)
downloadports-af4790a6153996202e85cba64aa9a222fcc62259.tar.gz
ports-af4790a6153996202e85cba64aa9a222fcc62259.zip
devel/py-thefuzz: Add new port
Fuzzy string matching like a boss. It uses Levenshtein Distance to calculate the differences between sequences in a simple-to-use package. WWW: https://github.com/seatgeek/thefuzz
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-thefuzz/Makefile17
-rw-r--r--devel/py-thefuzz/distinfo3
-rw-r--r--devel/py-thefuzz/pkg-descr4
4 files changed, 25 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index aa6816ef61a1..beb4f8c13e23 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5344,6 +5344,7 @@
SUBDIR += py-testresources
SUBDIR += py-testscenarios
SUBDIR += py-testtools
+ SUBDIR += py-thefuzz
SUBDIR += py-threema-msgapi
SUBDIR += py-thrift
SUBDIR += py-thriftpy2
diff --git a/devel/py-thefuzz/Makefile b/devel/py-thefuzz/Makefile
new file mode 100644
index 000000000000..a941e34d24eb
--- /dev/null
+++ b/devel/py-thefuzz/Makefile
@@ -0,0 +1,17 @@
+# Created by: Jason Helfman <jgh@FreeBSD.org>
+
+PORTNAME= thefuzz
+PORTVERSION= 0.19.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Fuzzy string matching in Python
+
+LICENSE= GPLv2
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-thefuzz/distinfo b/devel/py-thefuzz/distinfo
new file mode 100644
index 000000000000..8609248f87de
--- /dev/null
+++ b/devel/py-thefuzz/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1652554935
+SHA256 (thefuzz-0.19.0.tar.gz) = 6f7126db2f2c8a54212b05e3a740e45f4291c497d75d20751728f635bb74aa3d
+SIZE (thefuzz-0.19.0.tar.gz) = 28592
diff --git a/devel/py-thefuzz/pkg-descr b/devel/py-thefuzz/pkg-descr
new file mode 100644
index 000000000000..a5c4a3093033
--- /dev/null
+++ b/devel/py-thefuzz/pkg-descr
@@ -0,0 +1,4 @@
+Fuzzy string matching like a boss. It uses Levenshtein Distance to calculate
+the differences between sequences in a simple-to-use package.
+
+WWW: https://github.com/seatgeek/thefuzz