aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-08-02 13:20:32 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-08-03 19:06:27 +0000
commitaf5ca71360ea1baf370d74498b1556716db81ce5 (patch)
tree13a3ca9be605b90b4b376762e3cfcdc4cdd54624
parentca47904f783cbd03b7fe5520fa665540dd43ef5b (diff)
downloadports-af5ca71360ea1baf370d74498b1556716db81ce5.tar.gz
ports-af5ca71360ea1baf370d74498b1556716db81ce5.zip
devel/dasm: (Revive) Macro assembler with support for several 8-bit microprocessors
PR: 257563
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/dasm/Makefile34
-rw-r--r--devel/dasm/distinfo3
-rw-r--r--devel/dasm/pkg-descr5
5 files changed, 43 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 9ae4e414ab31..cb16125308a4 100644
--- a/MOVED
+++ b/MOVED
@@ -8258,7 +8258,6 @@ devel/py-EnthoughtBase||2016-07-04|Has expired: Broken for more than 6 months
devel/cl-uffi||2016-07-04|Has expired: Broken for more than 6 months
devel/ruby-event-loop||2016-07-04|Has expired: Broken for more than 6 months
devel/libqxt||2016-07-04|Has expired: Broken for more than 6 months
-devel/dasm||2016-07-04|Has expired: Broken for more than 6 months
devel/libopendaap||2016-07-04|Has expired: Broken for more than 6 months
devel/cl-uffi-sbcl||2016-07-04|Has expired: Depends on expiring devel/cl-uffi
devel/cvs2p4||2016-07-04|Has expired: Broken for more than 6 months
diff --git a/devel/Makefile b/devel/Makefile
index eea3cb4eff6c..f7fe176add0d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -459,6 +459,7 @@
SUBDIR += d-scanner
SUBDIR += darts
SUBDIR += dash.el
+ SUBDIR += dasm
SUBDIR += datadraw
SUBDIR += date
SUBDIR += dbus
diff --git a/devel/dasm/Makefile b/devel/dasm/Makefile
new file mode 100644
index 000000000000..157072bdf1bf
--- /dev/null
+++ b/devel/dasm/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= dasm
+DISTVERSION= 2.20.14.1
+CATEGORIES= devel
+
+MAINTAINER= fuz@fuz.su
+COMMENT= Macro assembler with support for several 8-bit microprocessors
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= dasm-assembler
+TEST_TARGET= test
+
+PLIST_FILES= bin/dasm \
+ bin/ftohex \
+ share/man/man1/dasm.1.gz
+PORTDOCS= dasm.txt \
+ dasm.pdf \
+ ftohex.txt
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dasm ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/ftohex ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/docs/dasm.1 ${STAGEDIR}${PREFIX}/share/man/man1
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/docs/${file} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/dasm/distinfo b/devel/dasm/distinfo
new file mode 100644
index 000000000000..295a043c0d27
--- /dev/null
+++ b/devel/dasm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1627909232
+SHA256 (dasm-assembler-dasm-2.20.14.1_GH0.tar.gz) = ec71ffd10eeaa70bf7587ee0d79a92cd3f0a017c0d6d793e37d10359ceea663a
+SIZE (dasm-assembler-dasm-2.20.14.1_GH0.tar.gz) = 980412
diff --git a/devel/dasm/pkg-descr b/devel/dasm/pkg-descr
new file mode 100644
index 000000000000..0b0241ea7ee1
--- /dev/null
+++ b/devel/dasm/pkg-descr
@@ -0,0 +1,5 @@
+DASM is a versatile macro assembler with support for several 8-bit
+microprocessors including MOS 6502 & 6507; Motorola 6803, 68705,
+and 68HC11; Hitachi HD6303 (extended Motorola 6801) and Fairchild F8.
+
+WWW: https://dasm-assembler.github.io/