aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-28 06:45:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-28 06:56:38 +0000
commitafe963c88eae88104bf139a3d4d3ac1d050e5d6b (patch)
treecace750c7c4c063751c395333b4bdd982243bd18
parentf3f5f2c79a582f2334991267edb2cac199074c05 (diff)
downloadports-afe963c88eae88104bf139a3d4d3ac1d050e5d6b.tar.gz
ports-afe963c88eae88104bf139a3d4d3ac1d050e5d6b.zip
devel/py-mypy-boto3-s3: New port: Type annotations for boto3.S3 service
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-mypy-boto3-s3/Makefile21
-rw-r--r--devel/py-mypy-boto3-s3/distinfo3
-rw-r--r--devel/py-mypy-boto3-s3/pkg-descr2
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 35c21befb8cc..23b5cbf11068 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4876,6 +4876,7 @@
SUBDIR += py-mutmut
SUBDIR += py-mygpoclient
SUBDIR += py-mypy
+ SUBDIR += py-mypy-boto3-s3
SUBDIR += py-mypy-protobuf
SUBDIR += py-mypy_extensions
SUBDIR += py-naiveBayesClassifier
diff --git a/devel/py-mypy-boto3-s3/Makefile b/devel/py-mypy-boto3-s3/Makefile
new file mode 100644
index 000000000000..f57a099b8d8b
--- /dev/null
+++ b/devel/py-mypy-boto3-s3/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= mypy-boto3-s3
+DISTVERSION= 1.26.58
+CATEGORIES= devel python
+MASTER_SITES= PYPI # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Type annotations for boto3.S3 service
+WWW= https://github.com/youtype/mypy_boto3_builder
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4.1.0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-mypy-boto3-s3/distinfo b/devel/py-mypy-boto3-s3/distinfo
new file mode 100644
index 000000000000..b7fea21da511
--- /dev/null
+++ b/devel/py-mypy-boto3-s3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674885985
+SHA256 (mypy-boto3-s3-1.26.58.tar.gz) = 02aa9514877147da996ea62e9d3d326d6b33f46c9c20b26f1e45fd125ba03518
+SIZE (mypy-boto3-s3-1.26.58.tar.gz) = 93365
diff --git a/devel/py-mypy-boto3-s3/pkg-descr b/devel/py-mypy-boto3-s3/pkg-descr
new file mode 100644
index 000000000000..58155664e108
--- /dev/null
+++ b/devel/py-mypy-boto3-s3/pkg-descr
@@ -0,0 +1,2 @@
+mypy-boto3-s3 contains type annotations for boto3.S3 1.26.58 service compatible
+with VSCode, PyCharm, Emacs, Sublime Text, mypy, pyright and other tools.