aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-05-06 12:01:00 +0000
committerWen Heping <wen@FreeBSD.org>2024-05-06 12:02:13 +0000
commitb01c9e078c07b4d9e6f981f5cd92e76d6f5ff0c3 (patch)
tree2b32333cfea8b205fd22cec96d47f197a5f5dc2c
parentb481defa675a20477146a6d4a9595cc2330b0ecc (diff)
downloadports-b01c9e078c07b4d9e6f981f5cd92e76d6f5ff0c3.tar.gz
ports-b01c9e078c07b4d9e6f981f5cd92e76d6f5ff0c3.zip
www/openemr: Add new port
OpenEMR is a Free and Open Source electronic health records and medical practice management application. It is ONC Certified and it features fully integrated electronic health records, practice management, scheduling, electronic billing, internationalization, free support, a vibrant community, and a whole lot more.
-rw-r--r--www/Makefile1
-rw-r--r--www/openemr/Makefile39
-rw-r--r--www/openemr/distinfo3
-rw-r--r--www/openemr/files/pkg-message.in26
-rw-r--r--www/openemr/pkg-descr5
5 files changed, 74 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 101edbb5d931..730a7d93ffde 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -491,6 +491,7 @@
SUBDIR += onionshare-cli
SUBDIR += onlyoffice-documentserver
SUBDIR += opencart
+ SUBDIR += openemr
SUBDIR += openresty
SUBDIR += orangehrm
SUBDIR += osrm-backend
diff --git a/www/openemr/Makefile b/www/openemr/Makefile
new file mode 100644
index 000000000000..ed9c745c091a
--- /dev/null
+++ b/www/openemr/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= openemr
+PORTVERSION= 7.0.2
+CATEGORIES= www
+MASTER_SITES= SF/openemr/OpenEMR%20Current/${PORTVERSION}/
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Electronic health records and medical practice management application
+WWW= https://www.open-emr.org/
+
+LICENSE= GPLv3
+LICENSE_FILES= ${WRKSRC}/LICENSE
+
+USES= cpe php:flavors
+USE_PHP= ctype curl gd json ldap mcrypt \
+ mbstring openssl pdo pdo_mysql \
+ session xml xmlreader xmlrpc xsl zip zlib
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= OPENEMRDIR=${OPENEMRDIR}
+
+OPENEMRDIR?= www/openemr
+
+post-patch:
+ @${RM} -rf ${WRKSRC}/.g*
+ @${RM} -rf ${WRKSRC}/.e*
+ @${RM} -rf ${WRKSRC}/.s*
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${OPENEMRDIR}?g" >>${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type l | ${SED} "s?${WRKSRC}?${OPENEMRDIR}?g" >>${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dir ${OPENEMRDIR}?g" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${OPENEMRDIR}
+
+.include <bsd.port.mk>
diff --git a/www/openemr/distinfo b/www/openemr/distinfo
new file mode 100644
index 000000000000..96f94b2a3a16
--- /dev/null
+++ b/www/openemr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1714915935
+SHA256 (openemr-7.0.2.tar.gz) = 70fded3f6f6dc0817b390ff32f442abd915198b8680369b0112b42d54bae1694
+SIZE (openemr-7.0.2.tar.gz) = 209854194
diff --git a/www/openemr/files/pkg-message.in b/www/openemr/files/pkg-message.in
new file mode 100644
index 000000000000..1bebbb3aa69c
--- /dev/null
+++ b/www/openemr/files/pkg-message.in
@@ -0,0 +1,26 @@
+[
+{ type: install
+ message: <<EOM
+
+1) Add the following to your Apache configuration file
+ httpd.conf, and restart the server:
+
+ Alias /openemr %%PREFIX%%/%%OPENEMRDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%OPENEMRDIR%%/>
+ AllowOverride None
+ Require all granted
+ </Directory>
+
+2) Visit your OpenEMR site with a browser (i.e.,
+ http://your.server.com/openemr/), and you should
+ be taken to the install script, which will lead
+ you through the installation step by step.
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ https://www.open-emr.org/wiki/index.php/OpenEMR_Installation_Guides
+
+EOM
+}
+]
diff --git a/www/openemr/pkg-descr b/www/openemr/pkg-descr
new file mode 100644
index 000000000000..0d60dbcf617f
--- /dev/null
+++ b/www/openemr/pkg-descr
@@ -0,0 +1,5 @@
+OpenEMR is a Free and Open Source electronic health records and medical
+practice management application. It is ONC Certified and it features
+fully integrated electronic health records, practice management, scheduling,
+electronic billing, internationalization, free support, a vibrant community,
+and a whole lot more.