aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-11-03 23:43:32 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2022-11-03 23:48:04 +0000
commitb048c3b1cd23c631fb0e48718231755361a08062 (patch)
tree622873131f2c9ebdcb5bd1affb5fb7d9ff96089c
parent55836daf2c06dffad37caa5e5c6d38d1c01abd62 (diff)
downloadports-b048c3b1cd23c631fb0e48718231755361a08062.tar.gz
ports-b048c3b1cd23c631fb0e48718231755361a08062.zip
security/yubikey-agent: Fix build on 32-bit platforms
This imports an upstream patch from dependency github.com/go-piv/piv-go to address a missing cast. See also: https://github.com/go-piv/piv-go/commit/1902689552e974ba88750e3ab71902d253172ead PR: 267197 Approved by: maintainer timeout, >2 weeks MFH: 2022Q4 (cherry picked from commit 302d7c2ddde491d2ab6bc7e25dad42d46509007f)
-rw-r--r--security/yubikey-agent/Makefile4
-rw-r--r--security/yubikey-agent/files/patch-vendor_github.com_go-piv_piv-go_piv_pcsc__freebsd.go12
2 files changed, 13 insertions, 3 deletions
diff --git a/security/yubikey-agent/Makefile b/security/yubikey-agent/Makefile
index 827c57eb2faf..7ac4b55dc5c3 100644
--- a/security/yubikey-agent/Makefile
+++ b/security/yubikey-agent/Makefile
@@ -1,7 +1,7 @@
PORTNAME= yubikey-agent
DISTVERSIONPREFIX= v
DISTVERSION= 0.1.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security sysutils
MAINTAINER= egypcio@FreeBSD.org
@@ -11,8 +11,6 @@ WWW= https://filippo.io/yubikey-agent
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_i386= constant 2148532270 overflows _Ctype_long
-
LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
RUN_DEPENDS= RSA_SecurID_getpasswd:devel/libccid
diff --git a/security/yubikey-agent/files/patch-vendor_github.com_go-piv_piv-go_piv_pcsc__freebsd.go b/security/yubikey-agent/files/patch-vendor_github.com_go-piv_piv-go_piv_pcsc__freebsd.go
new file mode 100644
index 000000000000..7b5f277f0a5d
--- /dev/null
+++ b/security/yubikey-agent/files/patch-vendor_github.com_go-piv_piv-go_piv_pcsc__freebsd.go
@@ -0,0 +1,12 @@
+armv7 build fix from github.com/gp-piv/piv-go upstream commit:
+https://github.com/go-piv/piv-go/commit/1902689552e974ba88750e3ab71902d253172ead
+
+--- vendor/github.com/go-piv/piv-go/piv/pcsc_freebsd.go.orig 2020-12-08 15:51:45 UTC
++++ vendor/github.com/go-piv/piv-go/piv/pcsc_freebsd.go
+@@ -26,5 +26,5 @@ func scCheck(rc C.long) error {
+ }
+
+ func isRCNoReaders(rc C.long) bool {
+- return rc == 0x8010002E
++ return uint32(rc) == 0x8010002E
+ }