aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-05-23 15:57:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-05-23 15:58:15 +0000
commitb09bfeaea3094bf68e2e11ab37a68550dc48a834 (patch)
tree4f63a3b67db8a4c3f3c853bb05a424a81476e816
parent9161cb3bced192dbe7765456685b035f28eb449b (diff)
downloadports-b09bfeaea3094bf68e2e11ab37a68550dc48a834.tar.gz
ports-b09bfeaea3094bf68e2e11ab37a68550dc48a834.zip
databases/{,py-}duckdb: update 0.10.2 → 0.10.3
Reported by: portscout
-rw-r--r--databases/duckdb/Makefile5
-rw-r--r--databases/duckdb/distinfo10
-rw-r--r--databases/duckdb/pkg-plist23
-rw-r--r--databases/py-duckdb/Makefile2
-rw-r--r--databases/py-duckdb/distinfo6
5 files changed, 33 insertions, 13 deletions
diff --git a/databases/duckdb/Makefile b/databases/duckdb/Makefile
index abde3f96cb27..3495a37a6fd8 100644
--- a/databases/duckdb/Makefile
+++ b/databases/duckdb/Makefile
@@ -1,6 +1,6 @@
PORTNAME= duckdb
DISTVERSIONPREFIX= v
-DISTVERSION= 0.10.2
+DISTVERSION= 0.10.3
CATEGORIES= databases
MAINTAINER= yuri@FreeBSD.org
@@ -12,7 +12,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake:testing compiler:c++11-lang ssl
USE_GITHUB= yes
-GH_TUPLE= duckdb:sqlite_scanner:091197e:sqlite/extension/sqlite_scanner
+GH_TUPLE= duckdb:sqlite_scanner:50b7870:sqlite/extension/sqlite_scanner
+# the list of out-of-tree extensions is here: .github/config/out_of_tree_extensions.cmake
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= BUILD_UNITTESTS
diff --git a/databases/duckdb/distinfo b/databases/duckdb/distinfo
index 96eb9b75c08c..0d685b9322b8 100644
--- a/databases/duckdb/distinfo
+++ b/databases/duckdb/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1713472441
-SHA256 (duckdb-duckdb-v0.10.2_GH0.tar.gz) = 662a0ba5c35d678ab6870db8f65ffa1c72e6096ad525a35b41b275139684cea6
-SIZE (duckdb-duckdb-v0.10.2_GH0.tar.gz) = 80028898
-SHA256 (duckdb-sqlite_scanner-091197e_GH0.tar.gz) = 213604e86866dd835bea6471906e250a448d3d0d6f9b06e9d2c76f227a3fd688
-SIZE (duckdb-sqlite_scanner-091197e_GH0.tar.gz) = 4647658
+TIMESTAMP = 1716475466
+SHA256 (duckdb-duckdb-v0.10.3_GH0.tar.gz) = 7855587b3491dd488993287caee28720bee43ae28e92e8f41ea4631e9afcbf88
+SIZE (duckdb-duckdb-v0.10.3_GH0.tar.gz) = 80169796
+SHA256 (duckdb-sqlite_scanner-50b7870_GH0.tar.gz) = f956100535e9cfdd955682de9a8d92ba3673db92b63f0b9b8c8508c71e4a20a2
+SIZE (duckdb-sqlite_scanner-50b7870_GH0.tar.gz) = 4649013
diff --git a/databases/duckdb/pkg-plist b/databases/duckdb/pkg-plist
index a7576107affd..d469ea1610bc 100644
--- a/databases/duckdb/pkg-plist
+++ b/databases/duckdb/pkg-plist
@@ -29,6 +29,7 @@ include/duckdb/catalog/catalog_entry/table_macro_catalog_entry.hpp
include/duckdb/catalog/catalog_entry/type_catalog_entry.hpp
include/duckdb/catalog/catalog_entry/view_catalog_entry.hpp
include/duckdb/catalog/catalog_entry_map.hpp
+include/duckdb/catalog/catalog_entry_retriever.hpp
include/duckdb/catalog/catalog_search_path.hpp
include/duckdb/catalog/catalog_set.hpp
include/duckdb/catalog/catalog_transaction.hpp
@@ -92,6 +93,7 @@ include/duckdb/common/enums/access_mode.hpp
include/duckdb/common/enums/aggregate_handling.hpp
include/duckdb/common/enums/catalog_lookup_behavior.hpp
include/duckdb/common/enums/catalog_type.hpp
+include/duckdb/common/enums/checkpoint_type.hpp
include/duckdb/common/enums/compression_type.hpp
include/duckdb/common/enums/cte_materialize.hpp
include/duckdb/common/enums/date_part_specifier.hpp
@@ -118,6 +120,7 @@ include/duckdb/common/enums/prepared_statement_mode.hpp
include/duckdb/common/enums/profiler_format.hpp
include/duckdb/common/enums/relation_type.hpp
include/duckdb/common/enums/scan_options.hpp
+include/duckdb/common/enums/scan_vector_type.hpp
include/duckdb/common/enums/set_operation_type.hpp
include/duckdb/common/enums/set_scope.hpp
include/duckdb/common/enums/set_type.hpp
@@ -156,12 +159,14 @@ include/duckdb/common/http_state.hpp
include/duckdb/common/hugeint.hpp
include/duckdb/common/index_map.hpp
include/duckdb/common/index_vector.hpp
+include/duckdb/common/insertion_order_preserving_map.hpp
include/duckdb/common/likely.hpp
include/duckdb/common/limits.hpp
include/duckdb/common/list.hpp
include/duckdb/common/local_file_system.hpp
include/duckdb/common/map.hpp
include/duckdb/common/memory_safety.hpp
+include/duckdb/common/multi_file_list.hpp
include/duckdb/common/multi_file_reader.hpp
include/duckdb/common/multi_file_reader_options.hpp
include/duckdb/common/mutex.hpp
@@ -185,6 +190,7 @@ include/duckdb/common/operator/string_cast.hpp
include/duckdb/common/operator/subtract.hpp
include/duckdb/common/optional_idx.hpp
include/duckdb/common/optional_ptr.hpp
+include/duckdb/common/optionally_owned_ptr.hpp
include/duckdb/common/pair.hpp
include/duckdb/common/perfect_map_set.hpp
include/duckdb/common/pipe_file_system.hpp
@@ -354,12 +360,13 @@ include/duckdb/execution/index/art/node256.hpp
include/duckdb/execution/index/art/node4.hpp
include/duckdb/execution/index/art/node48.hpp
include/duckdb/execution/index/art/prefix.hpp
+include/duckdb/execution/index/bound_index.hpp
include/duckdb/execution/index/fixed_size_allocator.hpp
include/duckdb/execution/index/fixed_size_buffer.hpp
include/duckdb/execution/index/index_pointer.hpp
include/duckdb/execution/index/index_type.hpp
include/duckdb/execution/index/index_type_set.hpp
-include/duckdb/execution/index/unknown_index.hpp
+include/duckdb/execution/index/unbound_index.hpp
include/duckdb/execution/join_hashtable.hpp
include/duckdb/execution/merge_sort_tree.hpp
include/duckdb/execution/nested_loop_join.hpp
@@ -410,6 +417,7 @@ include/duckdb/execution/operator/helper/physical_set.hpp
include/duckdb/execution/operator/helper/physical_streaming_limit.hpp
include/duckdb/execution/operator/helper/physical_streaming_sample.hpp
include/duckdb/execution/operator/helper/physical_transaction.hpp
+include/duckdb/execution/operator/helper/physical_update_extensions.hpp
include/duckdb/execution/operator/helper/physical_vacuum.hpp
include/duckdb/execution/operator/helper/physical_verify_vector.hpp
include/duckdb/execution/operator/join/outer_join_marker.hpp
@@ -516,6 +524,7 @@ include/duckdb/function/table/table_scan.hpp
include/duckdb/function/table_function.hpp
include/duckdb/function/table_macro_function.hpp
include/duckdb/function/udf_function.hpp
+include/duckdb/logging/http_logger.hpp
include/duckdb/main/appender.hpp
include/duckdb/main/attached_database.hpp
include/duckdb/main/buffered_data/buffered_data.hpp
@@ -531,6 +540,7 @@ include/duckdb/main/client_config.hpp
include/duckdb/main/client_context.hpp
include/duckdb/main/client_context_file_opener.hpp
include/duckdb/main/client_context_state.hpp
+include/duckdb/main/client_context_wrapper.hpp
include/duckdb/main/client_data.hpp
include/duckdb/main/client_properties.hpp
include/duckdb/main/config.hpp
@@ -546,6 +556,7 @@ include/duckdb/main/extension.hpp
include/duckdb/main/extension/generated_extension_loader.hpp
include/duckdb/main/extension_entries.hpp
include/duckdb/main/extension_helper.hpp
+include/duckdb/main/extension_install_info.hpp
include/duckdb/main/extension_util.hpp
include/duckdb/main/external_dependencies.hpp
include/duckdb/main/materialized_query_result.hpp
@@ -566,6 +577,7 @@ include/duckdb/main/relation/filter_relation.hpp
include/duckdb/main/relation/insert_relation.hpp
include/duckdb/main/relation/join_relation.hpp
include/duckdb/main/relation/limit_relation.hpp
+include/duckdb/main/relation/materialized_relation.hpp
include/duckdb/main/relation/order_relation.hpp
include/duckdb/main/relation/projection_relation.hpp
include/duckdb/main/relation/query_relation.hpp
@@ -601,7 +613,6 @@ include/duckdb/optimizer/filter_pushdown.hpp
include/duckdb/optimizer/in_clause_rewriter.hpp
include/duckdb/optimizer/join_order/cardinality_estimator.hpp
include/duckdb/optimizer/join_order/cost_model.hpp
-include/duckdb/optimizer/join_order/estimated_properties.hpp
include/duckdb/optimizer/join_order/join_node.hpp
include/duckdb/optimizer/join_order/join_order_optimizer.hpp
include/duckdb/optimizer/join_order/join_relation.hpp
@@ -639,6 +650,7 @@ include/duckdb/optimizer/rule/list.hpp
include/duckdb/optimizer/rule/move_constants.hpp
include/duckdb/optimizer/rule/ordered_aggregate_optimizer.hpp
include/duckdb/optimizer/rule/regex_optimizations.hpp
+include/duckdb/optimizer/rule/timestamp_comparison.hpp
include/duckdb/optimizer/statistics_propagator.hpp
include/duckdb/optimizer/topn_optimizer.hpp
include/duckdb/optimizer/unnest_rewriter.hpp
@@ -727,6 +739,7 @@ include/duckdb/parser/parsed_data/pragma_info.hpp
include/duckdb/parser/parsed_data/sample_options.hpp
include/duckdb/parser/parsed_data/show_select_info.hpp
include/duckdb/parser/parsed_data/transaction_info.hpp
+include/duckdb/parser/parsed_data/update_extensions_info.hpp
include/duckdb/parser/parsed_data/vacuum_info.hpp
include/duckdb/parser/parsed_expression.hpp
include/duckdb/parser/parsed_expression_iterator.hpp
@@ -769,10 +782,12 @@ include/duckdb/parser/statement/relation_statement.hpp
include/duckdb/parser/statement/select_statement.hpp
include/duckdb/parser/statement/set_statement.hpp
include/duckdb/parser/statement/transaction_statement.hpp
+include/duckdb/parser/statement/update_extensions_statement.hpp
include/duckdb/parser/statement/update_statement.hpp
include/duckdb/parser/statement/vacuum_statement.hpp
include/duckdb/parser/tableref.hpp
include/duckdb/parser/tableref/basetableref.hpp
+include/duckdb/parser/tableref/column_data_ref.hpp
include/duckdb/parser/tableref/emptytableref.hpp
include/duckdb/parser/tableref/expressionlistref.hpp
include/duckdb/parser/tableref/joinref.hpp
@@ -918,6 +933,7 @@ include/duckdb/planner/subquery/rewrite_cte_scan.hpp
include/duckdb/planner/table_binding.hpp
include/duckdb/planner/table_filter.hpp
include/duckdb/planner/tableref/bound_basetableref.hpp
+include/duckdb/planner/tableref/bound_column_data_ref.hpp
include/duckdb/planner/tableref/bound_cteref.hpp
include/duckdb/planner/tableref/bound_dummytableref.hpp
include/duckdb/planner/tableref/bound_expressionlistref.hpp
@@ -1019,6 +1035,7 @@ include/duckdb/storage/table/column_data_checkpointer.hpp
include/duckdb/storage/table/column_segment.hpp
include/duckdb/storage/table/column_segment_tree.hpp
include/duckdb/storage/table/data_table_info.hpp
+include/duckdb/storage/table/delete_state.hpp
include/duckdb/storage/table/list_column_data.hpp
include/duckdb/storage/table/persistent_table_data.hpp
include/duckdb/storage/table/row_group.hpp
@@ -1034,6 +1051,7 @@ include/duckdb/storage/table/struct_column_data.hpp
include/duckdb/storage/table/table_index_list.hpp
include/duckdb/storage/table/table_statistics.hpp
include/duckdb/storage/table/update_segment.hpp
+include/duckdb/storage/table/update_state.hpp
include/duckdb/storage/table/validity_column_data.hpp
include/duckdb/storage/table_io_manager.hpp
include/duckdb/storage/table_storage_info.hpp
@@ -1080,4 +1098,5 @@ lib/libduckdb_re2.a
lib/libduckdb_skiplistlib.a
lib/libduckdb_static.a
lib/libduckdb_utf8proc.a
+lib/libduckdb_yyjson.a
@dir include/duckdb/storage/serialization
diff --git a/databases/py-duckdb/Makefile b/databases/py-duckdb/Makefile
index 90bc1f262302..6070e707e5e6 100644
--- a/databases/py-duckdb/Makefile
+++ b/databases/py-duckdb/Makefile
@@ -1,5 +1,5 @@
PORTNAME= duckdb
-DISTVERSION= 0.10.2
+DISTVERSION= 0.10.3
CATEGORIES= databases python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/databases/py-duckdb/distinfo b/databases/py-duckdb/distinfo
index 8f033ea2c629..670801313f22 100644
--- a/databases/py-duckdb/distinfo
+++ b/databases/py-duckdb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1713476700
-SHA256 (duckdb-0.10.2.tar.gz) = 0f609c9d5f941f1ecde810f010dd9321cd406a552c1df20318a13fa64247f67f
-SIZE (duckdb-0.10.2.tar.gz) = 11248689
+TIMESTAMP = 1716476166
+SHA256 (duckdb-0.10.3.tar.gz) = c5bd84a92bc708d3a6adffe1f554b94c6e76c795826daaaf482afc3d9c636971
+SIZE (duckdb-0.10.3.tar.gz) = 11349245