aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-06-22 17:39:44 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-06-22 18:13:52 +0000
commitb0b997e3fc350bd39184128d1ec9434893e819d1 (patch)
tree53557c2a32716eab4823ec7c6ab44d02e2c24af2
parent2a14b05b62492ebb4c456815d141e32d64d79ce6 (diff)
downloadports-b0b997e3fc350bd39184128d1ec9434893e819d1.tar.gz
ports-b0b997e3fc350bd39184128d1ec9434893e819d1.zip
graphics/mesa-devel: unbreak standalone after e502b6db284d0
llvm-config found: NO found '9.0.1' but need '>= 11.0.0' Run-time dependency LLVM found: NO (tried cmake and config-tool) Looking for a fallback subproject for the dependency llvm (modules: bitwriter, engine, mcdisassembler, mcjit, core, executionengine, scalaropts, transformutils, instcombine, amdgpu, native, bitreader, ipo, asmparser) meson.build:1604:2: ERROR: Neither a subproject directory nor a llvm.wrap file was found.
-rw-r--r--graphics/mesa-devel/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/mesa-devel/Makefile b/graphics/mesa-devel/Makefile
index 10e1b7cd8a35..1c4afab5d440 100644
--- a/graphics/mesa-devel/Makefile
+++ b/graphics/mesa-devel/Makefile
@@ -94,7 +94,6 @@ anv_DESC= Haswell and newer
radv_DESC= Southern Islands and newer (implies LLVM)
COINST_DESC= Allow co-installation with another Mesa port
-COINST_VARS= LLVM_DEFAULT=11 # chase intel-compute-runtime
COINST_MESON_ON= -Degl-lib-suffix=${PKGNAMESUFFIX}
COINST_PLIST_SUB= SUFFIX=${PKGNAMESUFFIX}
COINST_SUB_FILES= libmap.conf
@@ -146,6 +145,13 @@ ZSTD_DESC= Use ZSTD for shader cache
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
ZSTD_MESON_ENABLED= zstd
+.include <bsd.port.options.mk>
+
+# Ignore Mk/bsd.default-versions.mk but respect make.conf(5)
+.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mllvm*}
+LLVM_DEFAULT= 11 # chase intel-compute-runtime
+.endif
+
post-extract:
# Work around Meson lookup order e.g., llvm-config
.if defined(BINARY_ALIAS)