aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPat Maddox <pat@patmaddox.com>2023-10-22 08:33:06 +0000
committerKurt Jaeger <pi@FreeBSD.org>2023-10-22 08:33:06 +0000
commitb0ebeff48e5e2dfcf470c59e0c8dfe7041da7d04 (patch)
tree72eedd34097180d2a361eeb11ccfadd0c6cb9da9
parenta98f932a68f6dc89221e27f2c58532591d32ada4 (diff)
downloadports-b0ebeff48e5e2dfcf470c59e0c8dfe7041da7d04.tar.gz
ports-b0ebeff48e5e2dfcf470c59e0c8dfe7041da7d04.zip
databases/py-dbt-core: new port
dbt enables data analysts and engineers to transform their data using the same practices that software engineers use to build applications. Analysts using dbt can transform their data by simply writing select statements, while dbt handles turning these statements into tables and views in a data warehouse. These select statements, or "models", form a dbt project. Models frequently build on top of one another - dbt makes it easy to manage relationships between models, and visualize these relationships, as well as assure the quality of your transformations through testing. PR: 274582 Author: Pat Maddox <pat@patmaddox.com>
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-dbt-core/Makefile41
-rw-r--r--databases/py-dbt-core/distinfo3
-rw-r--r--databases/py-dbt-core/pkg-descr11
4 files changed, 56 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 85b448bf071a..a9d000c30e9f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -756,6 +756,7 @@
SUBDIR += py-couchdb
SUBDIR += py-databases
SUBDIR += py-dbf
+ SUBDIR += py-dbt-core
SUBDIR += py-dbt-semantic-interfaces
SUBDIR += py-dbutils
SUBDIR += py-duckdb
diff --git a/databases/py-dbt-core/Makefile b/databases/py-dbt-core/Makefile
new file mode 100644
index 000000000000..ab50c57d2e6b
--- /dev/null
+++ b/databases/py-dbt-core/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= dbt-core
+PORTVERSION= 1.6.0
+CATEGORIES= databases python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= pat@patmaddox.com
+COMMENT= With dbt, build analytics the way engineers build applications
+WWW= https://github.com/dbt-labs/dbt-core
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}agate>=1.7,<2:textproc/py-agate@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=3.1.2,<4:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mashumaro>=3.8.1,<4:devel/py-mashumaro@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}msgpack>0:devel/py-msgpack@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}logbook>0:devel/py-logbook@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click<9:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}networkx>=2.3:math/py-networkx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}colorama>=0.3.9,<0.5:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pathspec>=0.9,<0.12:devel/py-pathspec@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}isodate>=0.6,<0.7:devel/py-isodate@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlparse>=0.2.3,<0.5:databases/py-sqlparse@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbt-extractor>=0.4.1,<-0.5:devel/py-dbt-extractor@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hologram>=0.0.16,0.1:devel/py-hologram@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}minimal-snowplow-tracker>=0.0.2,<0.1:devel/py-minimal-snowplow-tracker@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbt-semantic-interfaces>=0.2.0,<0.3:databases/py-dbt-semantic-interfaces@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>20.9:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=4.0.0:devel/py-protobuf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2015.7:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=6.0:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4:devel/py-typing-extensions@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}idna>0:dns/py-idna@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/databases/py-dbt-core/distinfo b/databases/py-dbt-core/distinfo
new file mode 100644
index 000000000000..0569abaa9854
--- /dev/null
+++ b/databases/py-dbt-core/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1691520002
+SHA256 (dbt-core-1.6.0.tar.gz) = 51da239af02ed449562d3c5caea903edee7b5427c47efd5a6439634c59858087
+SIZE (dbt-core-1.6.0.tar.gz) = 889429
diff --git a/databases/py-dbt-core/pkg-descr b/databases/py-dbt-core/pkg-descr
new file mode 100644
index 000000000000..17c93078fe10
--- /dev/null
+++ b/databases/py-dbt-core/pkg-descr
@@ -0,0 +1,11 @@
+dbt enables data analysts and engineers to transform their data using the same
+practices that software engineers use to build applications.
+
+Analysts using dbt can transform their data by simply writing select statements,
+while dbt handles turning these statements into tables and views in a data
+warehouse.
+
+These select statements, or "models", form a dbt project. Models frequently
+build on top of one another - dbt makes it easy to manage relationships between
+models, and visualize these relationships, as well as assure the quality of your
+transformations through testing.