aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-02-04 05:01:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-02-04 08:59:21 +0000
commitb16cb20707f77320126b8a1903a5ec622e6fb637 (patch)
tree1f8ce0b97d0012d721cae82ba3a849adbd619216
parent51c2aa8b3ea0da685786ef22cae4dc20fcaac862 (diff)
downloadports-b16cb20707f77320126b8a1903a5ec622e6fb637.tar.gz
ports-b16cb20707f77320126b8a1903a5ec622e6fb637.zip
graphics/ctl: New port: Color Transformation Language
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/ctl/Makefile38
-rw-r--r--graphics/ctl/distinfo5
-rw-r--r--graphics/ctl/pkg-descr2
-rw-r--r--graphics/ctl/pkg-plist40
5 files changed, 86 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index ee3008db37fc..b2205342d668 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -115,6 +115,7 @@
SUBDIR += cosmoplayer
SUBDIR += cptutils
SUBDIR += crw
+ SUBDIR += ctl
SUBDIR += curator
SUBDIR += curtail
SUBDIR += cuttlefish
diff --git a/graphics/ctl/Makefile b/graphics/ctl/Makefile
new file mode 100644
index 000000000000..ee4fbca0cb56
--- /dev/null
+++ b/graphics/ctl/Makefile
@@ -0,0 +1,38 @@
+PORTNAME= ctl
+DISTVERSIONPREFIX= ctl-
+DISTVERSION= 1.5.3
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -language
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 3871cd7717fd184d9fbb667730d35f1a89391f09.patch:-p1 # FreeBSD compatibility patch: https://github.com/ampas/CTL/pull/145
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Color Transformation Language
+WWW= https://github.com/ampas/CTL
+
+LICENSE= AMPAS
+LICENSE_NAME= Academy of Motion Picture Arts and Sciences (A.M.P.A.S.) license
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= auto-accept dist-mirror dist-sell pkg-mirror pkg-sell
+
+LIB_DEPENDS= libImath.so:math/Imath \
+ libOpenEXR.so:graphics/openexr \
+ libtiff.so:graphics/tiff
+
+USES= cmake:testing
+
+USE_GITHUB= yes
+GH_ACCOUNT= ampas
+GH_PROJECT= CTL
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= CTL_BUILD_TESTS
+CMAKE_TESTING_ON= CTL_BUILD_TESTS
+
+DATADIR= share/CTL
+DOCSDIR= share/doc/CTL
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.mk>
diff --git a/graphics/ctl/distinfo b/graphics/ctl/distinfo
new file mode 100644
index 000000000000..831eccc6084e
--- /dev/null
+++ b/graphics/ctl/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1707022854
+SHA256 (ampas-CTL-ctl-1.5.3_GH0.tar.gz) = 0a9f5f3de8964ac5cca31597aca74bf915a3d8214e3276fdcb52c80ad25b0096
+SIZE (ampas-CTL-ctl-1.5.3_GH0.tar.gz) = 3073036
+SHA256 (3871cd7717fd184d9fbb667730d35f1a89391f09.patch) = 3a77003f3474569de39f3b4270cd033c9cf6d22dce4d551fb1edcd6eb0fee30c
+SIZE (3871cd7717fd184d9fbb667730d35f1a89391f09.patch) = 1653
diff --git a/graphics/ctl/pkg-descr b/graphics/ctl/pkg-descr
new file mode 100644
index 000000000000..22b128c9db34
--- /dev/null
+++ b/graphics/ctl/pkg-descr
@@ -0,0 +1,2 @@
+The Color Transformation Language, or CTL, is a programming language for
+digital color management.
diff --git a/graphics/ctl/pkg-plist b/graphics/ctl/pkg-plist
new file mode 100644
index 000000000000..b797b5f996f1
--- /dev/null
+++ b/graphics/ctl/pkg-plist
@@ -0,0 +1,40 @@
+bin/ctlrender
+bin/exr_ctl_exr
+bin/exrdpx
+include/CTL/CtlAddr.h
+include/CTL/CtlAlign.h
+include/CTL/CtlColorSpace.h
+include/CTL/CtlErrors.h
+include/CTL/CtlExc.h
+include/CTL/CtlFunctionCall.h
+include/CTL/CtlInterpreter.h
+include/CTL/CtlLContext.h
+include/CTL/CtlLookupTable.h
+include/CTL/CtlMessage.h
+include/CTL/CtlModule.h
+include/CTL/CtlRbfInterpolator.h
+include/CTL/CtlRcPtr.h
+include/CTL/CtlReadWriteAccess.h
+include/CTL/CtlSimdInterpreter.h
+include/CTL/CtlSparseMatrix.h
+include/CTL/CtlStdType.h
+include/CTL/CtlSymbolTable.h
+include/CTL/CtlSyntaxTree.h
+include/CTL/CtlTokens.h
+include/CTL/CtlType.h
+include/CTL/CtlTypeStorage.h
+include/CTL/CtlVersion.h
+include/OpenEXR/ImfCtlApplyTransforms.h
+lib/libIlmCtl.so
+lib/libIlmCtl.so.1.5.3
+lib/libIlmCtlMath.so
+lib/libIlmCtlMath.so.1.5.3
+lib/libIlmCtlSimd.so
+lib/libIlmCtlSimd.so.1.5.3
+lib/libIlmImfCtl.so
+%%DATADIR%%/change_saturation.ctl
+%%DATADIR%%/transform_DPX_EXR.ctl
+%%DATADIR%%/transform_EXR_DPX.ctl
+%%DATADIR%%/utilities.ctl
+%%PORTDOCS%%%%DOCSDIR%%/CTL/CtlManual.doc
+%%PORTDOCS%%%%DOCSDIR%%/CTL/CtlManual.pdf