aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-01-02 18:39:15 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-01-04 18:00:58 +0000
commitb1951d0cb332f8494ab94ff5fa28c34dd4a55c18 (patch)
treea76c9e251bf0f23c60b283830718bf02da49d890
parent7c4c5b8d78d344e6d03f96138badfb31088decdc (diff)
downloadports-b1951d0cb332f8494ab94ff5fa28c34dd4a55c18.tar.gz
ports-b1951d0cb332f8494ab94ff5fa28c34dd4a55c18.zip
devel/kommit: Update to HEAD (1.3.1-20)
Version 1.3.1 was tagged, but distfiles ever since 1.0.2 have not been created as of writing for unknown reasons, so fetch from the upstream git repo instead. There exists a rather nasty bug that disrupts the space-time continuum in the v1.3.1 tag, however, where displayed commit dates are off by a factor of 10^-3, displaying milliseconds instead of seconds elapsed since the UNIX epoch. This has since been fixed in [1], but a new tag that includes this commit has yet to be created, so I'm just going with the latest commit which seems to build and run fine. Most of the other commits after the v1.3.1 tag are bot-created to update documentation and the human-created ones appear to be entirely reasonable. The main purpose of this update is to try to mitigate crashes with large and long-historied codebases like the FreeBSD src tree as reported in [2]. Upstream has migrated to using devel/libgit2 since the previous version (1.0.2) which makes kommit load very large trees noticably faster (anecdotally, 8-9 seconds faster for the entire FreeBSD src tree on my 4 year old laptop which is still rather slow at around 21 seconds, at least by modern expectations of instantaneous results, but a win is still a win). Plus it seems to be more stable in terms of closing cleanly on exit. For example, 1.0.2, likely unbeknownst to the user, would continue to consume roughly 4GB of RAM and happily burden 50% of a CPU core. It may have actually closed eventually, but after 5 minutes I got borded and terminated the process manually. I'm no longer seeing this behavior in 1.3.1-20, however. The application now exits almost immediately once the tree has been loaded and either window close or choosing Quit from the file menu (Ctrl+Q) has been selected. [1] https://invent.kde.org/sdk/kommit/-/commit/6d0a0bb043de981c3b4d7fe54debe49ead541dbe PR: 271683 [2] Reported by: grahamperrin [2]
-rw-r--r--devel/kommit/Makefile16
-rw-r--r--devel/kommit/distinfo6
-rw-r--r--devel/kommit/pkg-plist14
3 files changed, 22 insertions, 14 deletions
diff --git a/devel/kommit/Makefile b/devel/kommit/Makefile
index aa433f2632c3..d3c09f70c455 100644
--- a/devel/kommit/Makefile
+++ b/devel/kommit/Makefile
@@ -1,8 +1,6 @@
PORTNAME= kommit
-DISTVERSION= 1.0.2
-PORTREVISION= 1
+DISTVERSION= 1.3.1-20
CATEGORIES= devel kde
-MASTER_SITES= KDE/stable/${PORTNAME}/
MAINTAINER= kde@FreeBSD.org
COMMENT= Git GUI client for KDE
@@ -11,14 +9,20 @@ WWW= https://apps.kde.org/kommit/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake kde:5 localbase:ldflags pkgconfig qt:5 tar:xz xorg
+LIB_DEPENDS= libgit2.so:devel/libgit2 \
+ libdolphinvcs.so:x11-fm/dolphin
+
+USES= cmake compiler:c++17-lang kde:5 localbase:ldflags \
+ pkgconfig qt:5 xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons doctools i18n itemviews jobwidgets \
kio parts service solid sonnet syntaxhighlighting texteditor \
textwidgets widgetsaddons windowsystem xmlgui \
ecm:build
-USE_QT= concurrent core dbus gui network testlib widgets xml \
- buildtools:build qmake:build
+USE_QT= concurrent core dbus gui network widgets xml \
+ buildtools:build qmake:build testlib:build
USE_XORG= x11
+KDE_INVENT= fdfe7a23d95413007bbd6e26182dc423b2d6efa0 sdk
+
.include <bsd.port.mk>
diff --git a/devel/kommit/distinfo b/devel/kommit/distinfo
index 9729960968d4..b33cc62c8442 100644
--- a/devel/kommit/distinfo
+++ b/devel/kommit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1684318264
-SHA256 (kommit-1.0.2.tar.xz) = 1e8ecad23aa10508d0685a2e9169fc562e12fad5a6adaacd4542d9007a68e96e
-SIZE (kommit-1.0.2.tar.xz) = 1159416
+TIMESTAMP = 1704215721
+SHA256 (sdk-kommit-fdfe7a23d95413007bbd6e26182dc423b2d6efa0_GL0.tar.gz) = 31b35dcde4d142890ab1e667ac4ce1500a613d2175b64bbfbd2f42936b100629
+SIZE (sdk-kommit-fdfe7a23d95413007bbd6e26182dc423b2d6efa0_GL0.tar.gz) = 1508005
diff --git a/devel/kommit/pkg-plist b/devel/kommit/pkg-plist
index d4432b8ed6c7..7d18fb79bcc7 100644
--- a/devel/kommit/pkg-plist
+++ b/devel/kommit/pkg-plist
@@ -2,13 +2,14 @@ bin/kommit
bin/kommitdiff
bin/kommitmerge
lib/libkommit.so.0
-lib/libkommit.so.1.0.2
+lib/libkommit.so.1.4.0
lib/libkommitdiff.so.0
-lib/libkommitdiff.so.1.0.2
+lib/libkommitdiff.so.1.4.0
lib/libkommitgui.so.0
-lib/libkommitgui.so.1.0.2
-%%QT_PLUGINDIR%%/kf5/kfileitemaction/kommititemaction.so
-%%QT_PLUGINDIR%%/kf5/overlayicon/kommitoverlayplugin.so
+lib/libkommitgui.so.1.4.0
+lib/libkommitwidgets.so.0
+lib/libkommitwidgets.so.1.4.0
+%%QT_PLUGINDIR%%/dolphin/vcs/kommitdolphinplugin.so
share/applications/org.kde.kommit.desktop
share/applications/org.kde.kommit.diff.desktop
share/applications/org.kde.kommit.merge.desktop
@@ -53,6 +54,7 @@ share/locale/ca@valencia/LC_MESSAGES/kommit.mo
share/locale/cs/LC_MESSAGES/kommit.mo
share/locale/de/LC_MESSAGES/kommit.mo
share/locale/en_GB/LC_MESSAGES/kommit.mo
+share/locale/eo/LC_MESSAGES/kommit.mo
share/locale/es/LC_MESSAGES/kommit.mo
share/locale/eu/LC_MESSAGES/kommit.mo
share/locale/fi/LC_MESSAGES/kommit.mo
@@ -60,12 +62,14 @@ share/locale/fr/LC_MESSAGES/kommit.mo
share/locale/it/LC_MESSAGES/kommit.mo
share/locale/ja/LC_MESSAGES/kommit.mo
share/locale/ka/LC_MESSAGES/kommit.mo
+share/locale/ko/LC_MESSAGES/kommit.mo
share/locale/lt/LC_MESSAGES/kommit.mo
share/locale/nl/LC_MESSAGES/kommit.mo
share/locale/pl/LC_MESSAGES/kommit.mo
share/locale/pt/LC_MESSAGES/kommit.mo
share/locale/sk/LC_MESSAGES/kommit.mo
share/locale/sl/LC_MESSAGES/kommit.mo
+share/locale/sv/LC_MESSAGES/kommit.mo
share/locale/tr/LC_MESSAGES/kommit.mo
share/locale/uk/LC_MESSAGES/kommit.mo
share/locale/zh_CN/LC_MESSAGES/kommit.mo