aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Nagy <robert@openbsd.org>2022-07-16 10:15:36 +0000
committerRene Ladan <rene@FreeBSD.org>2022-07-19 19:56:43 +0000
commitb2193c3c801075a5b0d985d50b2e25dba4c9b6b4 (patch)
tree71b3bd101a7711e13676bb6d157a42c88f47f734
parent38c74de9d54d2f98cf1245941e2bd5453156d01b (diff)
downloadports-b2193c3c801075a5b0d985d50b2e25dba4c9b6b4.tar.gz
ports-b2193c3c801075a5b0d985d50b2e25dba4c9b6b4.zip
www/chromium: unbundle icu to use icu from ports
(cherry picked from commit 55b20cdeb6569e0e3c63d58aedd679901d15dc50) PR: 265180
-rw-r--r--www/chromium/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index e00dae9997eb..dcd4697f3768 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,7 +2,7 @@
PORTNAME= chromium
PORTVERSION= 103.0.5060.114
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
https://nerd.hu/distfiles/:external
@@ -99,6 +99,7 @@ GN_ARGS+= clang_use_chrome_plugins=false \
enable_remoting=false \
enable_wmax_tokens=false \
fatal_linker_warnings=false \
+ icu_use_data_file=false \
is_clang=true \
optimize_webui=true \
toolkit_views=true \
@@ -256,7 +257,7 @@ pre-configure:
#./build/linux/unbundle/remove_bundled_libraries.py [list of preserved]
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} \
./build/linux/unbundle/replace_gn_files.py --system-libraries \
- flac fontconfig freetype harfbuzz-ng libdrm libevent libpng \
+ flac fontconfig freetype harfbuzz-ng icu libdrm libevent libpng \
libusb libwebp libxml libxslt openh264 opus snappy || ${FALSE}
# Chromium uses an unreleased version of FFmpeg, so configure it
.for brand in Chrome Chromium
@@ -300,7 +301,7 @@ do-install:
.for d in protoc mksnapshot
${INSTALL_PROGRAM} ${WRKSRC}/out/${BUILDTYPE}/${d} ${STAGEDIR}${DATADIR}
.endfor
-.for d in icudtl.dat snapshot_blob.bin v8_context_snapshot.bin
+.for d in snapshot_blob.bin v8_context_snapshot.bin
${INSTALL_DATA} ${WRKSRC}/out/${BUILDTYPE}/${d} ${STAGEDIR}${DATADIR}
.endfor
${INSTALL_PROGRAM} ${WRKSRC}/out/${BUILDTYPE}/chrome \