aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2023-11-16 14:00:30 +0000
committerNicola Vitale <nivit@FreeBSD.org>2023-11-16 14:02:41 +0000
commitb28009e43f476bdd33d0d97bfa3bd56739c45ff4 (patch)
treeb3cc14e854c9c19e86fa67298b37e1db08981e3f
parent50d2fdf85d45fdcc211086be0893c6132642877a (diff)
downloadports-b28009e43f476bdd33d0d97bfa3bd56739c45ff4.tar.gz
ports-b28009e43f476bdd33d0d97bfa3bd56739c45ff4.zip
textproc/py-mdformat: Add new port
Mdformat is an opinionated Markdown formatter that can be used to enforce a consistent style in Markdown files. Mdformat is a Unix-style command-line tool as well as a Python library. https://github.com/executablebooks/mdformat
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-mdformat/Makefile42
-rw-r--r--textproc/py-mdformat/distinfo3
-rw-r--r--textproc/py-mdformat/pkg-descr3
4 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 9ccd5e143e62..c825dad404e8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1421,6 +1421,7 @@
SUBDIR += py-markups
SUBDIR += py-markupsafe
SUBDIR += py-mathics-pygments
+ SUBDIR += py-mdformat
SUBDIR += py-mdit-py-plugins
SUBDIR += py-mdurl
SUBDIR += py-merge3
diff --git a/textproc/py-mdformat/Makefile b/textproc/py-mdformat/Makefile
new file mode 100644
index 000000000000..d89d85a45161
--- /dev/null
+++ b/textproc/py-mdformat/Makefile
@@ -0,0 +1,42 @@
+PORTNAME= mdformat
+DISTVERSION= 0.7.17
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= CommonMark compliant Markdown formatter
+WWW= https://github.com/executablebooks/mdformat
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.0.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.41.3:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=3.6.0:devel/py-importlib-metadata@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}markdown-it-py>=1.0.0<4.0.0:textproc/py-markdown-it-py@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mdurl>=0.1.2:textproc/py-mdurl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tomli>=1.1.0:textproc/py-tomli@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zipp>=0.5:devel/py-zipp@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>=4.1.0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-randomly>=3.12.0:devel/py-pytest-randomly@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= executablebooks
+USE_PYTHON= autoplist pep517 pytest
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0.18.1:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}furo>=2022.6.21:textproc/py-furo@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}myst-parser>=0.18.0:textproc/py-myst-parser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=5.4.0:textproc/py-sphinx@${PY_FLAVOR}
+DOCS_PORTDOCS= * .buildinfo
+
+post-install-DOCS-on:
+ ${LOCALBASE}/bin/sphinx-build-${PYTHON_VER} \
+ -d ${WRKDIR} -b html -n ${WRKSRC}/docs ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/py-mdformat/distinfo b/textproc/py-mdformat/distinfo
new file mode 100644
index 000000000000..8f702bf34718
--- /dev/null
+++ b/textproc/py-mdformat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1700138821
+SHA256 (executablebooks-mdformat-0.7.17_GH0.tar.gz) = 833919e616c64cba88b8af09e485cd6b440366f572f963f2b18ea89b0d5c4416
+SIZE (executablebooks-mdformat-0.7.17_GH0.tar.gz) = 81766
diff --git a/textproc/py-mdformat/pkg-descr b/textproc/py-mdformat/pkg-descr
new file mode 100644
index 000000000000..159a9450b840
--- /dev/null
+++ b/textproc/py-mdformat/pkg-descr
@@ -0,0 +1,3 @@
+Mdformat is an opinionated Markdown formatter that can be used to enforce a
+consistent style in Markdown files. Mdformat is a Unix-style command-line tool
+as well as a Python library.