aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:45:45 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:07 +0000
commitb28ce2b070b5d87efee192c2c7bf641ddcef0d76 (patch)
treefcdda4170175cccad65a07e984a5c394988cbb5d
parent022d383b0e704ad9bdb02255c8ef0c47c52416ed (diff)
downloadports-b28ce2b070b5d87efee192c2c7bf641ddcef0d76.tar.gz
ports-b28ce2b070b5d87efee192c2c7bf641ddcef0d76.zip
devel/py-unearth: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-unearth/Makefile7
-rw-r--r--devel/py-unearth/files/setup.py59
2 files changed, 3 insertions, 63 deletions
diff --git a/devel/py-unearth/Makefile b/devel/py-unearth/Makefile
index 399cb32cb47c..54c5cf3f7527 100644
--- a/devel/py-unearth/Makefile
+++ b/devel/py-unearth/Makefile
@@ -1,5 +1,6 @@
PORTNAME= unearth
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,7 @@ WWW= https://github.com/frostming/unearth
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdm-pep517>=0:devel/py-pdm-pep517@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=20:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.25:www/py-requests@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=2.1.2:www/py-flask@${PY_FLAVOR} \
@@ -19,7 +21,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=2.1.2:www/py-flask@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}trustme>=0.9.0:security/py-trustme@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
@@ -29,7 +31,4 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cached-property>=1.5.2:devel/py-cached-property@${PY_FLAVOR}
.endif
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.post.mk>
diff --git a/devel/py-unearth/files/setup.py b/devel/py-unearth/files/setup.py
deleted file mode 100644
index 0b7bc64588f8..000000000000
--- a/devel/py-unearth/files/setup.py
+++ /dev/null
@@ -1,59 +0,0 @@
-# -*- coding: utf-8 -*-
-from setuptools import setup
-
-import codecs
-
-with codecs.open('README.md', encoding="utf-8") as fp:
- long_description = fp.read()
-INSTALL_REQUIRE = [
- 'packaging>=20',
- 'requests>=2.25',
- 'cached-property>=1.5.2; python_version < "3.8"',
-]
-EXTRAS_REQUIRE = {
- 'keyring': [
- 'keyring',
- ],
-}
-ENTRY_POINTS = {
- 'console_scripts': [
- 'unearth = unearth.__main__:cli',
- ],
-}
-
-setup_kwargs = {
- 'name': 'unearth',
- 'version': '%%PORTVERSION%%',
- 'description': 'A utility to fetch and download python packages',
- 'long_description': long_description,
- 'license': 'MIT',
- 'author': '',
- 'author_email': 'Frost Ming <me@frostming.com>',
- 'maintainer': None,
- 'maintainer_email': None,
- 'url': '',
- 'packages': [
- 'unearth',
- 'unearth.vcs',
- ],
- 'package_dir': {'': 'src'},
- 'package_data': {'': ['*']},
- 'long_description_content_type': 'text/markdown',
- 'classifiers': [
- 'Development Status :: 3 - Alpha',
- 'Intended Audience :: Developers',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3 :: Only',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: 3.9',
- 'Programming Language :: Python :: 3.10',
- 'Programming Language :: Python :: 3.11',
- ],
- 'install_requires': INSTALL_REQUIRE,
- 'extras_require': EXTRAS_REQUIRE,
- 'python_requires': '>=3.7',
- 'entry_points': ENTRY_POINTS,
-}
-
-setup(**setup_kwargs)