aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-01-18 10:55:11 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-01-18 11:00:32 +0000
commitb29347d0d51a7583aa87acdb3fa425022b8c0c1d (patch)
treefdb9d90734554cf6720cf70988c4ba338edd7fc3
parent03236bf4cd3013f19e8a02525f24a386c6cfcaa6 (diff)
downloadports-b29347d0d51a7583aa87acdb3fa425022b8c0c1d.tar.gz
ports-b29347d0d51a7583aa87acdb3fa425022b8c0c1d.zip
audio/mumble: fixed dependencies after update devel/protobuf to 24.x
After update devel/protobuf to 24.x mumble started link with dosen libabsl_*.so from devel/abseil. While here: audio/mumble doesn't use GL - remove it from dependencies. Approved by: arrowd (mentor, implicit) MFH: 2024Q1
-rw-r--r--audio/mumble/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index aed5ba9b4aad..3996b22cd445 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mumble
DISTVERSION= 1.5.517
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= https://github.com/${PORTNAME}-voip/${PORTNAME}/releases/download/v${DISTVERSION}/
@@ -21,16 +21,16 @@ BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
LIB_DEPENDS= libsndfile.so:audio/libsndfile \
libopus.so:audio/opus \
libspeexdsp.so:audio/speexdsp \
+ libabsl_base.so:devel/abseil \
libpcre2-8.so:devel/pcre2 \
libPocoXML.so:devel/poco \
libPocoZip.so:devel/poco \
libprotobuf.so:devel/protobuf \
libexpat.so:textproc/expat2
-USES= cmake compiler:c++17-lang cpe desktop-file-utils gl \
+USES= cmake compiler:c++17-lang cpe desktop-file-utils \
pkgconfig python:build qt:5 ssl xorg
USE_CXXSTD= c++17
-USE_GL= gl
USE_LDCONFIG= yes
USE_QT= buildtools:build concurrent core gui l10n linguist:build network \
qmake:build sql sql-sqlite3:run svg widgets xml