aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-09-11 19:03:27 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-09-20 19:37:14 +0000
commitb2e49cc576b595d18f6b56112eb2cd0284cc05d0 (patch)
treeff8a845a6589ec4b347a434c7b972a259b20675a
parent747f48bdbe8d4d38eb5041336c72bc0009745768 (diff)
downloadports-b2e49cc576b595d18f6b56112eb2cd0284cc05d0.tar.gz
ports-b2e49cc576b595d18f6b56112eb2cd0284cc05d0.zip
devel/intel-graphics-compiler: update to 1.0.8708
-rw-r--r--devel/intel-graphics-compiler/Makefile7
-rw-r--r--devel/intel-graphics-compiler/distinfo12
-rw-r--r--devel/intel-graphics-compiler/files/patch-strerror_r23
-rw-r--r--devel/intel-graphics-compiler/pkg-plist1
4 files changed, 28 insertions, 15 deletions
diff --git a/devel/intel-graphics-compiler/Makefile b/devel/intel-graphics-compiler/Makefile
index c2c931c6ef12..ad3f7ff7c2e6 100644
--- a/devel/intel-graphics-compiler/Makefile
+++ b/devel/intel-graphics-compiler/Makefile
@@ -1,13 +1,8 @@
PORTNAME= intel-graphics-compiler
DISTVERSIONPREFIX= igc-
-DISTVERSION= 1.0.8517
+DISTVERSION= 1.0.8708
CATEGORIES= devel
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= ef9a69ee4723.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/189
-PATCHFILES+= 8888a28132ac.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/189
-PATCHFILES+= b926d2c2f490.patch:-p1 # https://github.com/intel/intel-graphics-compiler/pull/189
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Intel Graphics Compiler for OpenCL
diff --git a/devel/intel-graphics-compiler/distinfo b/devel/intel-graphics-compiler/distinfo
index 7566046d95a9..ed7c408bbe01 100644
--- a/devel/intel-graphics-compiler/distinfo
+++ b/devel/intel-graphics-compiler/distinfo
@@ -1,9 +1,3 @@
-TIMESTAMP = 1629709130
-SHA256 (intel-intel-graphics-compiler-igc-1.0.8517_GH0.tar.gz) = b6bcac1e598a51d7ca54a97d746f5f9ddd619d4cd23fd3fa3e63f181fce5de17
-SIZE (intel-intel-graphics-compiler-igc-1.0.8517_GH0.tar.gz) = 7539946
-SHA256 (ef9a69ee4723.patch) = 3468a505bff2a3793530f8e14cadcaba33859899855447230c00b8f45476cccd
-SIZE (ef9a69ee4723.patch) = 1199
-SHA256 (8888a28132ac.patch) = 74e2be5a81e3ed91286d6f0e7fba07b5eb1542fffbeb4394be40d4585515548b
-SIZE (8888a28132ac.patch) = 1160
-SHA256 (b926d2c2f490.patch) = d126535816d8daa42abb480c7a5ae627abe4655e26de84a65daca9c6203f2f32
-SIZE (b926d2c2f490.patch) = 4441
+TIMESTAMP = 1631387007
+SHA256 (intel-intel-graphics-compiler-igc-1.0.8708_GH0.tar.gz) = 08dc2d4b93be77b024a9cf76ebfdc5013c5c756fd9bd73a10e4da78e6b6a560e
+SIZE (intel-intel-graphics-compiler-igc-1.0.8708_GH0.tar.gz) = 7574517
diff --git a/devel/intel-graphics-compiler/files/patch-strerror_r b/devel/intel-graphics-compiler/files/patch-strerror_r
new file mode 100644
index 000000000000..d5996876448f
--- /dev/null
+++ b/devel/intel-graphics-compiler/files/patch-strerror_r
@@ -0,0 +1,23 @@
+POSIX version of strerror_r returns int
+
+visa/iga/IGALibrary/system.cpp:263:14: error: assigning to 'char *' from incompatible type 'int'
+ errMsg = strerror_r(errCode, buf, sizeof(buf));
+ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+--- visa/iga/IGALibrary/system.cpp.orig 2021-09-11 19:03:27 UTC
++++ visa/iga/IGALibrary/system.cpp
+@@ -259,8 +259,13 @@ std::string iga::FormatLastError(unsigned errCode)
+ NULL);
+ if (errMsg)
+ msg = errMsg;
+-#else
++#elif defined(__GLIBC__)
+ errMsg = strerror_r(errCode, buf, sizeof(buf));
++#else
++ if (strerror_r(errCode, buf, sizeof(buf)))
++ errMsg = nullptr;
++ else
++ errMsg = buf;
+ #endif // _WIN32
+ if (errMsg == nullptr || errMsg[0] == 0)
+ return "???";
diff --git a/devel/intel-graphics-compiler/pkg-plist b/devel/intel-graphics-compiler/pkg-plist
index 968e8aebed31..da47de31c31a 100644
--- a/devel/intel-graphics-compiler/pkg-plist
+++ b/devel/intel-graphics-compiler/pkg-plist
@@ -74,6 +74,7 @@ include/igc/ocl_igc_interface/impl/ocl_translation_output_impl.cpp
include/igc/ocl_igc_interface/impl/ocl_translation_output_impl.h
include/igc/ocl_igc_interface/impl/platform_impl.cpp
include/igc/ocl_igc_interface/impl/platform_impl.h
+include/igc/ocl_igc_interface/impl/version_in.h
include/igc/ocl_igc_interface/ocl_gen_binary.h
include/igc/ocl_igc_interface/ocl_translation_output.h
include/igc/ocl_igc_interface/platform.h