aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2024-04-21 01:14:34 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2024-04-21 01:14:34 +0000
commitb301b38dc59e6cb86a9f9379c9e11d860c02e2c9 (patch)
tree80edbb51eb8ab8b6b7f42c12a51662c33a2f894b
parentc4eb9478257e33a0e2c9de216fe4503127f3abef (diff)
downloadports-b301b38dc59e6cb86a9f9379c9e11d860c02e2c9.tar.gz
ports-b301b38dc59e6cb86a9f9379c9e11d860c02e2c9.zip
devel/papi: Mark as BROKEN
Build fails as following. cc -shared -Xlinker "-soname" -Xlinker "libpapi.so" -Xlinker "-rpath" -Xlinker "/usr/local/lib" -DPIC -fPIC -I. -Ifreebsd -I. -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -g -DSTATIC_PAPI_EVENTS_TABLE -D_REENTRANT -D_GNU_SOURCE -DNO_TLS -I. -Ifreebsd -DPIC -fPIC -DPAPI_NO_MEMORY_MANAGEMENT -DOSLOCK=\"freebsd-lock.h\" -DOSCONTEXT=\"freebsd-context.h\" -O2 -DPAPI_NO_MEMORY_MANAGEMENT x86_cpuid_info.c freebsd/map-unknown.c freebsd/map.c freebsd/map-p6.c freebsd/map-p6-m.c freebsd/map-p6-3.c freebsd/map-p6-2.c freebsd/map-p6-c.c freebsd/map-k7.c freebsd/map-k8.c freebsd/map-p4.c freebsd/map-atom.c freebsd/map-core.c freebsd/map-core2.c freebsd/map-core2-extreme.c freebsd/map-i7.c freebsd/map-westmere.c papi.c papi_internal.c papi_hl.c extras.c sw_multiplex.c papi_fwrappers.c papi_fwrappers_.c papi_fwrappers__.c upper_PAPI_FWRAPPERS.c threads.c cpus.c freebsd-memory.c freebsd.c papi_preset.c papi_vector.c papi_memory.c -o libpapi.so.5.4.3.0 -lpmc papi_fwrappers.c:751:12: warning: address of array 'info.note' will always evaluate to 'true' [-Wpointer-bool-conversion] if (info.note) ~~ ~~~~~^~~~ 1 warning generated. papi_fwrappers.c:751:12: warning: address of array 'info.note' will always evaluate to 'true' [-Wpointer-bool-conversion] if (info.note) ~~ ~~~~~^~~~ 1 warning generated. papi_fwrappers.c:751:12: warning: address of array 'info.note' will always evaluate to 'true' [-Wpointer-bool-conversion] if (info.note) ~~ ~~~~~^~~~ 1 warning generated. papi_fwrappers.c:751:12: warning: address of array 'info.note' will always evaluate to 'true' [-Wpointer-bool-conversion] if (info.note) ~~ ~~~~~^~~~ 1 warning generated. freebsd.c:361:92: error: too few arguments to function call, expected 6, have 5 if ((ret = pmc_allocate (ctrl->counters[i], PMC_MODE_TC, 0, PMC_CPU_ANY, &(ctrl->pmcs[i]))) < 0) ~~~~~~~~~~~~ ^ /usr/include/pmc.h:75:5: note: 'pmc_allocate' declared here int pmc_allocate(const char *_ctrspec, enum pmc_mode _mode, uint32_t _flags, ^ freebsd.c:827:73: error: too few arguments to function call, expected 6, have 5 if ( (ret = pmc_allocate (name, PMC_MODE_TC, 0, PMC_CPU_ANY, &pmcs[i])) < 0) ~~~~~~~~~~~~ ^ /usr/include/pmc.h:75:5: note: 'pmc_allocate' declared here int pmc_allocate(const char *_ctrspec, enum pmc_mode _mode, uint32_t _flags, ^ 2 errors generated. papi_preset.c:849:2: warning: 'memset' will always overflow; destination buffer has size 1024, but size argument is 2048 [-Wfortify-source] memset( &stack, 0, 2*PAPI_HUGE_STR_LEN ); ^ 1 warning generated. gmake: *** [Makefile.inc:61: libpapi.so.5.4.3.0] Error 1 *** Error code 1 Stop. make: stopped in /usr/ports/devel/papi PR: 277899 Approved by: maintainer timeout
-rw-r--r--devel/papi/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/papi/Makefile b/devel/papi/Makefile
index 3dd6cc319092..c5b885b3cbb1 100644
--- a/devel/papi/Makefile
+++ b/devel/papi/Makefile
@@ -11,6 +11,8 @@ WWW= https://code.google.com/p/papi-for-freebsd/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/LICENSE.txt
+BROKEN= freebsd.c:361:92: error: too few arguments to function call, expected 6, have 5
+
TEST_TARGET= fulltest
ONLY_FOR_ARCHS= i386 amd64