aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2021-07-04 10:53:23 +0000
committerThomas Zander <riggs@FreeBSD.org>2021-07-05 17:07:21 +0000
commitb335da9d6354c82e3ae53696938f62d334d1c668 (patch)
tree7fcd0a57a9cce00583653cd3435a04444b80f529
parent1665e1b849df4100658e9d502cc0175c997a40ed (diff)
downloadports-b335da9d6354c82e3ae53696938f62d334d1c668.tar.gz
ports-b335da9d6354c82e3ae53696938f62d334d1c668.zip
multimedia/(mplayer|mencoder): Update to upstream snapshot 2021-07-03.
MFH: 2021Q3 (cherry picked from commit 56f8f0ac2a21e1672029d3c59aeec07a5532029f)
-rw-r--r--multimedia/mencoder/Makefile1
-rw-r--r--multimedia/mencoder/distinfo6
-rw-r--r--multimedia/mplayer/Makefile1
-rw-r--r--multimedia/mplayer/Makefile.common2
-rw-r--r--multimedia/mplayer/distinfo6
-rw-r--r--multimedia/mplayer/files/patch-libao2_ao__oss.c11
6 files changed, 11 insertions, 16 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index 28b5c8eaadcd..2df6b5c12581 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -2,7 +2,6 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
-PORTREVISION= 1
CATEGORIES= multimedia audio
MAINTAINER= riggs@FreeBSD.org
diff --git a/multimedia/mencoder/distinfo b/multimedia/mencoder/distinfo
index d1f256eeef77..1e75807866db 100644
--- a/multimedia/mencoder/distinfo
+++ b/multimedia/mencoder/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1615850499
-SHA256 (mplayer-1.4.0.20210314.tar.xz) = 7709f988fadcd24c00cc27b8c2d775dbb2e75e6b8bdc682b13ae6b66cc0a5174
-SIZE (mplayer-1.4.0.20210314.tar.xz) = 5194236
+TIMESTAMP = 1625393918
+SHA256 (mplayer-1.4.0.20210703.tar.xz) = 7c81c590215436d2365b98324e3903e92958722e06eb7ebc9f20192e8a99a6ab
+SIZE (mplayer-1.4.0.20210703.tar.xz) = 5195192
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index d9cb87a4df7d..09ddd828f6a4 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -2,7 +2,6 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
-PORTREVISION= 1
CATEGORIES= multimedia audio
MAINTAINER= riggs@FreeBSD.org
diff --git a/multimedia/mplayer/Makefile.common b/multimedia/mplayer/Makefile.common
index f7701abd85f0..dd35b9a35e45 100644
--- a/multimedia/mplayer/Makefile.common
+++ b/multimedia/mplayer/Makefile.common
@@ -3,7 +3,7 @@
# before we include bsd.port.pre.mk
MPLAYER_PORT_VERSION= 1.4.0
-MPLAYER_SNAPSHOT_DATE= 2021-03-14
+MPLAYER_SNAPSHOT_DATE= 2021-07-03
MASTER_SITES= LOCAL/riggs/mplayer
DISTNAME= mplayer-${MPLAYER_PORT_VERSION}.${MPLAYER_SNAPSHOT_DATE:S/-//g}
WRKSRC= ${WRKDIR}/mplayer-export-${MPLAYER_SNAPSHOT_DATE}
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index b91ba38d8b1a..3933f63c3152 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1615840634
-SHA256 (mplayer-1.4.0.20210314.tar.xz) = 7709f988fadcd24c00cc27b8c2d775dbb2e75e6b8bdc682b13ae6b66cc0a5174
-SIZE (mplayer-1.4.0.20210314.tar.xz) = 5194236
+TIMESTAMP = 1625328221
+SHA256 (mplayer-1.4.0.20210703.tar.xz) = 7c81c590215436d2365b98324e3903e92958722e06eb7ebc9f20192e8a99a6ab
+SIZE (mplayer-1.4.0.20210703.tar.xz) = 5195192
diff --git a/multimedia/mplayer/files/patch-libao2_ao__oss.c b/multimedia/mplayer/files/patch-libao2_ao__oss.c
index fd7fb8d6fa64..431cfe198dc3 100644
--- a/multimedia/mplayer/files/patch-libao2_ao__oss.c
+++ b/multimedia/mplayer/files/patch-libao2_ao__oss.c
@@ -1,4 +1,4 @@
---- libao2/ao_oss.c.orig 2016-02-26 20:47:16 UTC
+--- libao2/ao_oss.c.orig 2021-04-15 19:26:53 UTC
+++ libao2/ao_oss.c
@@ -57,6 +57,8 @@ static const ao_info_t info =
""
@@ -129,13 +129,10 @@
oss_format = format2oss(ao_data.format);
if(AF_FORMAT_IS_AC3(ao_data.format))
fail |= ioctl (audio_fd, SNDCTL_DSP_SPEED, &ao_data.samplerate) == -1;
-@@ -467,14 +543,15 @@ static void reset(void){
- int c = ao_data.channels-1;
- fail |= ioctl (audio_fd, SNDCTL_DSP_STEREO, &c) == -1;
- }
-- fail |= ioctl (audio_fd, SNDCTL_DSP_SPEED, &ao_data.samplerate) == -1;
+@@ -471,11 +547,14 @@ static void reset(void){
}
-- mp_msg(MSGT_AO,MSGL_WARN, "OSS: Reset failed\n");
+ if (fail)
+ mp_msg(MSGT_AO,MSGL_WARN, "OSS: Reset failed\n");
+ setfragment(audio_fd);
+ restorevol();
}